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1.0  Introduction 
 
This document contains detailed instructions to run the PRODAF (Probabilistic Design and Analysis 
Framework) software tool. PRODAF is a practical, multidisciplinary,  design-for-reliability  methodology 
for aerospace systems.  It allows system-level reliability constraints to impact component-level designs 
and interfaces user-selected, physics-based deterministic modeling codes with a Fast Probability 
Integration code to obtain high-fidelity probabilistic component failure rate data. The computed 
component failure rates may be input into a system-level probabilistic risk assessment code such as QRAS 
or SAPHIRE. A feedback loop from the risk assessment tool to the analysis/design tools enables the 
system-level reliability constraint to affect the component design. Accuracy measures of the probability 
calculations (confidence intervals) are provided to account for uncertainties in the uncertainty parameters. 
Design variable optimization is accelerated through the use of adaptive response surface modeling. On-
screen results are presented graphically in terms of CDF/PDF plots and sensitivity charts. A companion 
theoretical manual (Ref. 1) provides additional information about the methodologies implemented within 
PRODAF.   
 
An executive overview of PRODAF is provided in another companion volume (Ref. 2). Readers are 
encouraged to read the executive overview volume first to gain a perspective of PRODAF’s intended 
function and its general capabilities and features. 
 
While online help provisions are incorporated into PRODAF, this is a complex, immature code that deals 
with many external user-supplied codes. Consequently there are more than the usual number of potential 
software glitches during actual usage.  Users are encouraged to submit problem reports directly to N&R 
Engineering (bstrack@nrengineering.com).   
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2.0  Installing PRODAF 
 

The PRODAF framework is normally installed using the Install-PRODAF code.  Clicking its icon will 
initiate the installation procedure. Several options are available such as the location of the installation.  
Another useful option is to install the Probabilistic Manager code as a standalone generic probabilistic 
tool  without invoking PRODAF.  This code, formerly known as SUA (Systems Uncertainty Analysis), is 
useful when a simple probabilistic analysis is desired without navigating the full-blown PRODAF design 
system interfaces. 
 
This code suite is available only on Windows platforms using Win2000 or later operating systems. All 
PRODAF files are located within the installation folder although several registry entries are created to 
facilitate user preferences.  Note however, that to use PRODAF productively, the user must inform it 
which modeling/analysis codes are accessible to the user and the associated installation folders. This 
information is stored within a text-based database file called CodeDB located in the PRODAF installation 
folder. Design/analysis code information may be created, modified, or deleted from this database via the 
Code Database Manager code. Initially, only several example codes are available since many, if not 
most, codes to be used with PRODAF will have restricted distributions.  
 
The various user codes that PRODAF interfaces with may be located anywhere on the users computer or 
on a network. There is no need to copy or relocate the codes PRODAF interfaces with; they may stay 
wherever the user prefers.  However, PRODAF does maintain a separate folder to contain the PRODAF-
specific files associated with each “project” – a “project” is identified by a configuration file that defines 
a particular design problem. These project-specific folders are all located within a master folder called 
CodeData which is located in the installation folder.  For example, after a default installation, with two 
projects defined (Project A and Project B) the PRODAF file structure would be as shown in Figure 2.1. 
 
                           
 

 

 

 

 

 

 

 
Figure 2.1 – The PRODAF installation file structure. 
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3.0  Getting Started 
 
After a successful installation, PRODAF may be launched using the desktop PRODAF icon. Initially, the 
framework is all that exists. To make it useful, users need to populate the code database so PRODAF has 
something to work with. To do this, first read the section below entitled “Code Database Manager.” Then 
run PRODAF and add codes that you have access to (either locally on your own computer or accessible 
via a network) in the Code Library Manager on the left-hand side of the PRODAF window. Codes are 
added to the library by right-clicking anywhere within the pane or on an existing code. This action will 
display a context menu. Select Add and a new entry will appear in the library that you can name whatever 
you choose. It need not be the executable name, it should be a simple, easy-to-recognize name. Then right 
click this newly created entry to again display the context menu. This time, select Code Editor and the 
Code Database Editor will appear into which you should provide the necessary attributes of this new 
code entry (read the section below entitled Code Database Editor for help with this step). Dismiss this 
dialog and repeat this procedure for each code you wish PRODAF to handle. The Code Database Editor 
can also be invoked by selecting Tools > Code database editor from the menu.   
  
Several application codes are included with the installation to provide experience in using PRODAF. 
These are non-proprietary, simple analysis codes that execute very rapidly to avoid impeding the learning 
process. They will appear in the Code Library Manager during the first PRODAF run and their usage 
with the PRODAF tools is described in the “Example Problems” section near the end of this manual: 
 
• Quadratic: Evaluates the quadratic function   
  
      Y1 = 1 + (x1-1)2 + 2(x2-2)2 + 3(x3 -3)2 + 4(x4-4)2 
 
• Quadradic-CT: Evaluates the quadratic function containing cross terms 
 
                  y2 = 1 + x12 + 2x22 + 3x32 + 4x42 + 5x2x3 + 6x1x4 
 
• Cubic: Evaluates the cubic function  
 

        Y3 = x13 + x23 - 18 
 
• Launch_vehicle: Computes the approximate payload of a single stage launch vehicle given 6 

parameters; namely, the initial mass, the engine’s average specific impulse Isp, the velocity 
increment (ΔV) required to attain orbit, the tankage mass ratio, the engine mass ratio, and the 
structural mass ratio.   

 
One of the examples illustrates the technique of defining a design process involving multiple 
modeling/analysis codes and data transfer interfacing. The two codes in this example  (NEPP and 
FLOPS) are not in the public domain and therefore are not included with the PRODAF installation. 
However, they may be obtained through NASA points of contact1 if desired.  
 

                     
1 NEPP point of contact: Christopher Snyder, NASA Glenn Research Center, Cleveland, Ohio 
(Christopher.A.Snyder@grc.nasa.gov).  FLOPS point of contact:  Arnie McCullers, ATK Space 
(L.A.McCullers@larc.nasa.gov). 
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Figure 4.1 – Example design process architecture 

4.0  Methodology 
 
PRODAF is not a traditional computer code in the sense that it does not have a pre-defined order of 
execution. The “F” in PRODAF stands for “Framework” and this means that it provides a suite of tools 
that enable users to define their own design processes and perform a number of related tasks. Some users 
may simply wish to use PRODAF to perform probabilistic analyses with a single simulation code. Others 
may choose to link several codes together to perform a complex design task involving optimization. The 
latter may involve calculating system-level reliability after a series of component-level reliability 
computations.   
 
An example design architecture is illustrated in Figure 4.1 in which the physics-based deterministic codes 
are linked to a generic Fast Probabilistic Integration code (FPI), a module from the NESTEM code (Ref. 
3), to generate the model-based reliability data needed by the QRAS (or SAPHIRE) system-level 
reliability code (Ref. 4).  A feedback loop interfaces each component’s design variable set to system-level 
reliability (or other criteria) and thus 
provides a mechanism to intelligently 
set the design variables. 
 
This particular design process 
architecture is a baseline template that 
can be modified by users to suit their 
specific needs. What is important is 
that the methodology permits users to 
define the design process in terms of 
the sequence of codes to be used, 
linkages between the codes, 
uncertainties, and roll multiple 
component-level physics-based 
reliability results upward to a system-
level Probabilistic Risk Assessment 
tool.    
 
The prototype PRODAF software suite 
that was developed to implement this 
methodology consists of a number of  
integrated tools – all of which are 
invoked from a single executive that is 
illustrated in Figure 4.2. 
 
These tools are described sequentially in this manual; namely, 
 
• Code Library Manager – Maintains a list of codes available to synthesize a design process. 
• Design Process Manager – A graphical representation of the user-defined design process 

indicating the code execution sequence and data transfer linkages. 
• Code Database Editor – Edits the code database. The code database tells PRODAF where codes 

are installed, the executable file name, the input file name, et cetera. 
• Probabilistic Manager – Configures and controls the execution of probabilistic analyses.  
• Executing the Design Process – Overall description of executing a design process (not a tool). 
• Single Design Point Calculation – Executes the design process for a single design point.  
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• Parametric Design Space Exploration – Determines the response function parametrically for a 
set of design variables. Can also generate a response surface and ascertain its accuracy.  

• Design Point Optimization – Searches the design space to locate an optimum design point 
subject to constraints. Utilizes an optimal symmetric Latin hypercube procedure to select design 
points that are used to generate a response surface that accelerates the search. May also use a 
global-local adaptive search technique that progressively shrinks the response surface boundaries 
to further improve optimization efficiency. 

• Most Probable Point (MPP) search – Given a set of design variables and associated  
uncertainties, search for the most probable point using the adaptive response surface method and 
optimal symmetric Latin hypercube sampling technique mentioned above.   

• Data Exchange Interfaces – A dialog to define the data transfer interfaces between codes.  
• Progressive Failure Analysis – Implements a methodology to perform analysis of structures that 

fail in a progressive fashion – a sequence of failed components that eventually lead to total system 
failure.  

• Online help system – Provides online help information. 
• Utility Tools – Auxiliary standalone convenience tools: A random data sampling tool and a 

database viewer. 
 
There are a large number of dialogs associated with PRODAF, many of them are similar to another but 
differ in subtle ways. The major dialogs are all described herein, but many of the minor dialogs 
(particularly ones notifying users of an error condition) are not described because they are self-
explanatory and may never (or only rarely) be encountered.  
 

Figure 4.2 – The main PRODAF user interface. The Code Library Manager is on the left and the Design Process 
Manager is on the right. 
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Figure 5.2 – The Code Library 
Manager context menu. 

5.0  Code Library Manager 
 
This tool is used to construct a decomposition of all 
design/analysis codes available to the user. The codes are 
displayed in a hierarchical tree as illustrated in Figure 5.1. 
The organization of this display may be edited into 
whatever categories the user defines (e.g., Conceptual 
Design, Preliminary Design, Detailed Design, CAD, and 
System Risk Assessment). Users may add, edit, and delete 
entries in this tree using the context menu (Fig. 5.2) 
associated with each item, or relocate items using 
conventional drag-and-drop techniques. The hierarchy of 
codes displayed within the Code Library Manager may also 
be saved and retrieved using the File > Save and File > 
Open menu items. Although the main purpose of the Code 
Library Manager is to help users visualize the code choices 
they have in a single display, the codes may also be invoked 
using the tree – either through the context menu or by 
double clicking an item. The context menu method offers a 
choice of running the selected code deterministically or 
probabilistically while the double-click method is limited to 
deterministic runs.  Invoking codes from the Code Library 
Manager is facilitated by a database that links the code 
names to user-selected executable files as well as 
input/output file names and any command-line options. This 
means that the codes in the library need not be located in 
one central directory; rather, they can be located wherever 
users happen to have them.  Additional information is added 
to this database for probabilistic invocations; namely, the 
name of an uncertainty configuration file used by FPI. 
 
Selecting a code from the 
library and then selecting 
Add to the design 
process from the context 
menu creates an icon for 
this code in the Design 
Process Manager. Note 
that users must populate 
the code library with their 
own codes. The PRODAF 
installation does not 
provide all of the codes 
displayed in Figure 5.1. 
 

 
 
 
 

Figure 5.1 – The Code Library Manager 
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6.0  Design Process Manager 
 
This tool enables users to configure the design process; that is, select which specific codes will be used 
and the linkages between them as well as visualize the configuration on-screen as illustrated in Figure 6.1. 
Any codes in the Code Library Manager list may be added to the design process diagram. The code 
symbolic representations (the gray boxes) may be repositioned and resized, as well as linked to other 
codes. These linkages indicate data transfer paths within the design process and imply a behind-the-
scenes interface to accomplish the transfer. Labels may be added to indicate the associated components. 
Similarly, numbers are 
automatically added to the links 
(displayed within circles) to 
specify the execution sequence.  
The circular execution sequence 
numbers may be colored either 
green or yellow.  Green indicates 
that the interface exists whereas 
yellow means PRODAF cannot 
locate a suitable interface. The 
sequence numbers may be 
modified by the user to ensure 
proper execution. Any of the codes 
may be invoked either 
deterministically or 
probabilistically (if appropriate) 
using a context menu (Fig. 6.2). 
 
The example displayed in Figure 
6.1 represents a design process for 
a 3-component rotor assembly 
consisting of a shaft, a disk, and a 
set of 24 blades. The geometry for 
each component is generated by 
ANSYS, the structural modeling 
and analysis is performed by 
NESTEM, and the system 
reliability is determined by QRAS. 
 An interface module is also required to handle the data transfer from NESTEM to QRAS since QRAS 1.7 
does not support user-supplied input and output files (although it does save and restore user data supplied 
via its GUI in binary database tables). This interface module enables users to modify the QRAS binary 
database tables. 
 
Specific instructions on how to manipulate this diagram: 
 
• Create a code icon (gray boxes): Right-click a code in the Code 

Library Manager to display the context menu. Select Add to design 
process.  A corresponding icon will appear on the Design Process 
Manager window. If a same-named icon already exists on the 
design window, both icons will be given sequentially numbered 
suffixes to ensure uniqueness (as illustrated in Fig. DPM-1 for the 

Figure 6.1 – Design Process Manager window with a example design 
process illustrated. 

Figure 6.2 – Context menu 
for code icons. 
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ANSYS and NESTEM codes). 
• Move a code icon: Click the icon and hold the left mouse button down while moving the mouse.  
• Resize a code icon: Same procedure as moving an icon, but also hold the Control key down 

simultaneously. 
• Create a link between 2 codes: Step 1: Select Link this code with another from the context 

menu of the source icon. Step 2: Repeat this procedure for the destination icon. A connecting link 
and sequence number will be drawn. 

• Label a link: Right click a link and select Add label to link from the context menu. Existing 
labels may be edited by right-clicking them and selecting an appropriate action (re-label, delete, 
change color). 

• Delete a link: Right-clink a link to display its context menu and select Delete link. 
• Unlink a code: Right click a code icon and select Unlink this code.  All links connecting this 

code will be deleted. 
• Label a link: Right-click a link and select Add label to link from the context menu. 
• Change the sequence number of a link: Right-click a link and select Change sequence from the 

context menu. 
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7.0  Code Database Editor 
 
PRODAF needs to know where the codes it is asked to execute are located on the user’s computer system. 
It also needs to know the name of the execution file, the name of the input file, any command line 
arguments, the name of the file that defines the probabilistic configuration (if any), and possibly other 
data. Figure 7.1 illustrates this editor using NASAlife as an example code. 
 

  
The codes currently in the database are presented in the list on the left-hand side. In this example, 
NASAlife is selected so its data populates the data entry boxes on the right.  Codes may be added or 
deleted from this list using the buttons beneath the list. The entries are: 
 
• Code name – This is merely a label for the convenience of the user to identify the code together 

with the attributes defined below. Hence, the same executable code can appear in the editor 
multiple times, but with a different code name and presumably with different attributes such as the 
uncertainty data file. 

• Installation folder path – The full path name of the code’s installation. 
• Executable file – The executable file name. Most file names will have the extension “exe” but 

Excel files will have the extension “xls”. 
• Main input file – This is the name of the file that the executable loads treats as the main input file. 

In many cases there is only a single input file, but other codes may have several. 
• Command line arguments – Any command line arguments are entered here. In the example 

displayed, NASAlife expects the names of the input and output files to be present on the command 
line. 

Figure 7.1 – The Code Database Editor.  
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• Uncertainty data file – Codes that might be interfaced to FPI for probabilistic analyses must 
include a configuration file that identifies and characterizes the uncertainties. This file is where 
such data is kept and it has the extension “sua”. Several alternative configuration files may exist 
for the same “Code name”. This entry specifies the one that the Probabilistic Manager will load 
first. Any others may be loaded by the Probabilistic Manager if the user chooses. Codes that are 
not viable candidates for probabilistic analyses should have the Deterministic only checkbox 
checked. 

• Exclusive input file name – By default, PRODAF will assign an input file name of its own 
choosing whenever a probabilistic analysis is performed. It will be a copy of the file named under 
“Main input file” but modified slightly to generate perturbation data. However, some executable 
codes are hard-wired to expect a fixed input file name. In such cases, this entry tells PRODAF to 
only use the file name specified here.  

• Exclusive output file name – By default, PRODAF will assign an output file name of its own 
choosing whenever a probabilistic analysis is performed.  However, some executable codes are 
hard-wired with a fixed output file name. In such cases, this entry tells PRODAF to only use the 
file name specified here.  
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8.0  Probabilistic Manager 
 
During the design process it may be desirable to conduct a probabilistic analysis of a specific model in 
order to determine the impact of its input uncertainties. The results of such a probabilistic analysis in the 
form of CDF curves may then be transmitted to a system-level reliability code such as QRAS to predict 
system-level reliability.  The PRODAF tool used to perform probabilistic analyses is known as the 
Probabilistic Manager2. The basic philosophy is to utilize existing deterministic simulation codes 
together with a graphical user interface and an approximate, but rapid, probabilistic methodology to 
generate solutions accounting for uncertainties. The architectural concept is to leave the existing 
simulation codes untouched – to simply use them as is -- because modifying them prevents future 
versions from being utilized unless they too are similarly modified. This tool enables users to define and 
characterize uncertainties associated with variables within text input files for a specific code. It 
automatically creates and runs a script file that invokes the code multiple times to obtain the probabilistic 
response data required in the probabilistic analysis performed by the FPI code (Fast Probabilistic 
Analysis)3. Any executable code or Excel spreadsheet is a candidate for the Probabilistic Manager. Once 
the probabilistic data has been generated, FPI may be invoked to generate and display the results in the 
form of CDF/PDF curves and probabilistic sensitivity charts. Figure 8.1 summarizes the overall 
probabilistic analysis process implemented in PRODAF. In essence, a set of perturbation runs of a user-
selected simulation code are harvested for their response variables in order to obtain the input required for 
FPI. FPI uses this data to 
perform a probabilistic analysis. 
Figure 8.2 displays a typical 
Probabilistic Manager user 
interface for handling 
uncertainties associated with a 
typical deterministic simulation 
code (the Launch_Vehicle code 
estimates the payload mass and 
fuel mass for a fixed gross 
takeoff weight launch vehicle). 
The uncertainties are 
enumerated in the table in the 
upper-left together with their 
mean values, coefficients of 
variation, and types of 
distribution. Response variables 
are listed in the lower left table 
(two in this example).  
Users are offered several 
methods to specify the uncertainty characteristics and inform PRODAF how to locate these variables in 
the input file(s) and locate the response variables in the output file(s) as illustrated in the right-hand 
portion of Figure PM-2 for one uncertainty (tank mass ratio). Many legacy deterministic codes use 
labeled input and output files making it convenient to specify uncertainties using keywords. However, 
some codes use fixed-field formatted input/output files with no labeling – just lines of numbers. Such 
codes require specifying the uncertainties and response variables in a row-column format.. Array 
variables representing curves are handled in addition to scalar variables, and auxiliary input files may also 
                     
2 The Probabilistic Manager code is an enhanced version of a code formerly known as SUA (Systems Uncertainty 
Analysis).  It can also be invoked as a standalone code for problems not involving an entire design process. 
3 The FPI code is a subset of the NASA-sponsored NESSUS probabilistic structural analysis code. It is a slightly 
modified version of the FPI-specific portions of NESSUS.  In fact, NESSUS can be used as an alternative to FPI. 

Figure 8.1- PRODAF’s probabilistic analysis process. 
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be specified. The lower portion of  the uncertainty definition dialog (see Figure 8.2) is used to set the 
distribution type and its parameters, and to graphically display the PDF curve for each uncertainty. 
Current distributions include: Normal, 
lognormal, Weibull, Frechet, Beta, modified 
Beta, truncated Normal, truncated Weibull, 
uniform, maximum entropy, extreme value, 
and user-defined polynomial curve. 
Distribution-specific parameters are 
specified by the user in the edit boxes and 
these are transformed by PRODAF into 
equivalent mean and COV values that are 
displayed in the main uncertainty window. 
PDF plots may be displayed so users can 
visualize the impact of contemplated 
parameter changes.  
 
A similar dialog is used to define response 
function variables. Once all the 
uncertainties and response functions are 
defined, users may ask PRODAF to 
generate a dataset of responses that will 
subsequently be used by the FPI code to 
calculate probabilistic results. The response 
dataset is produced by invoking the Figure 8.3 – Probabilistic analysis results charts. 

Figure 8.2- Probabilistic Manager tool illustrated with a typical example application code. 
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simulation code (Launch_Vehicle in this example) multiple times – a process that is controlled 
automatically by PRODAF. Subsequently, the FPI code may be invoked to perform a probabilistic 
analysis and display the results as shown in Figure 8.3.  
 
Both CDF and PDF curves may be plotted as well as a probabilistic sensitivity chart that indicates which 
uncertainties have the greatest impact on the response function(s). Users are offered considerable 
flexibility in defining the methodology used in the probabilistic analysis: 

• Linear or quadratic limit state function regression approximation 

• Positive, negative, or central difference perturbations 

• Coefficient-of-variation (COV) or standard deviation specification of the uncertainties 

• Display of traditional deterministic sensitivities or probabilistic sensitivity factors 

The Probabilistic Manager may be used at whatever stage within the design process the user feels it 
would be helpful to generate probabilistic results. 

Probabilistic Manager input dialogs – The Probabilistic Manager may be invoked in two ways from 
within PRODAF: 

• Selecting Probabilistic Manager from the Tools main menu. In this case, the tool will attempt to 
reload the most recent configuration file used by the tool. The configuration file identifies and 
characterizes the uncertainties and response variables. 

• Right-clicking one of the code icons in the Design Process Manager window and selecting “Run 
probabilistically” from the context menu. This method also applies to entries in the Code Library 
Manager. In either case, the tool will attempt to load the configuration file associated with the 
specific code that was right-clicked. Note that the term “code” used here actually refers to a 
specific instantiation of the code; that is, the executable together with specific input/output file(s) 
and uncertainty data. Note: there might be more than one instantiation of the same code, but each 
with its own configuration. The user previously created a identifying label for each instantiation 
and this is what the Probabilistic Manager uses to locate the corresponding configuration file. 

If the Probabilistic Manager locates and loads a valid configuration file, the left-hand dialog will be filled 
with uncertainty data that was previously defined. Otherwise, the dialog will be empty and waiting for the 
user to input uncertainty information.  On the right-hand side of the screen, a text editor will appear that 
initially contains the baseline (deterministic) input file. The standard editing tools of cut, copy, and paste 
are available.  Printing and saving options are also included. A list of the most recently used files is 
available for opening under the File menu. The main use of the text editor is to modify the baseline input 
file, examine output files, and to examine intermediate files for debugging purposes.  

Users may define, save, and reload several configuration files for the same code using the File menu 
options. (Configuration files are named *.sua).  Figure 8.4 depicts a typical dialog with 5 uncertainties 
enumerated and control definitions notated at the sides. The controls are mostly self-explanatory with 2 
exceptions: 

• The check boxes at the extreme left signify which uncertainties are active – meaning that 
unchecked entries will be ignored during execution of the simulation code or the FPI code.  

• Editing uncertainty characteristics may be initiated either by highlighting an entry in the 
uncertainty table and then clicking the Modify uncertainty button, or by simply double-
clicking the entry. Either action will display another dialog that is used to edit the uncertainty 
data. 



   16 

 

In Figure 8.4, five uncertainties are listed in the table. All are checked so all will be used in any code 
invocations triggered by clicking either the “Run simulation” button or the “Run FPI” button. Two 
response variables are listed and one is checked. Although all response variables will be harvested from 
the simulation code output files, only the checked response variable will be used if FPI is invoked. 

The uncertainty table identifies the uncertainties using a user-selected label (column 2). The other 3 
columns (Mean, COV, and Distribution) specify the primary parameters and contain the data transmitted 
to FPI.  However, specifying uncertainties requires additional information in order to locate the numerical 
values within the input file(s). The additional information is specified in the Uncertainty Definition dialog 
that is displayed whenever an uncertainty table item is double-clicked, or the “Modify uncertainty” button 
is clicked. Clicking “Add uncertainty” also brings up this dialog (Figure 8.5). To delete an uncertainty, 
highlight it in the table by clicking anywhere on its table entry line and then click the “Delete uncertainty” 
button.  Multiple entries may be selected for deletion by holding down the keyboard Shift or Control 
keys.        

Activating the “Uncertainty definition” dialog (Fig. 8.5) is required to add or edit an uncertainty. The 
“Uncertainty label” identifies each uncertainty uniquely.  Two options are available to inform PRODAF 
how to locate an uncertainty variable within a text input file:  
 

• The keyword option can be used whenever a uncertainty variable can be identified by a keyword 
followed by a numerical value.  Intervening non-numeric characters such as spaces or equal signs 
are ignored; hence an input line containing the string “Isp 390” is treated the same as an input line 

Figure 8.4 – The Probabilistic Manager main dialog. 
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containing the string “Isp=390”.  If the target numeric value is not in the first column to the right 
of the keyword, indicate this by editing the column box.  For example, specifying column 3 for 
the line “Isp=390  420  430  440” would target the value 430. 

 
• The line-column option may be used in situations where no keywords exist. For example, if the 

input lines were: 
 

  123.456   99.000   100.12345    1.345e-9 
        123.987   95.123   102.5555    -2.345e+8 

 
and the user wished to declare the entry “-2.345e+8” as an uncertainty, he would enter a 2 and a 4 
into the corresponding line and column edit boxes.   

   

 

Figure 8.5 – The Uncertainty Definition dialog. 
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Some uncertainty variables may be located in an auxiliary input file instead of the main input file (which 
is specified in the configuration file).  In such cases, specify the auxiliary file name in the edit box 
provided. 

Sometimes an entire vector of values (representing a curve) is the uncertainty. If this is the case, 
PRODAF can be instructed to treat the entire vector as a single uncertainty by checking the This 
uncertainty is an array box and specifying the number of elements and the array format (all on a line or 
all in a column). An additional requirement for array uncertainties is that the mean value should be 
specified as unity. PRODAF will then treat the entire array with a uniform COV value applied to each 
element. 

Finally, the lower section of this dialog specifies the uncertainty characteristics in terms of a distribution 
type and its corresponding parameters. The distribution type4 is selected in the drop-down combo box and 
the corresponding parameter labels and entry boxes will appear below. Since FPI requires mean and COV 
(or standard deviation) parameters, all distribution types whose native parameters differ from this 
requirement will have their native parameter values transformed into mean and COV values. These 
transformed values will also be displayed, but in grayed boxes to signify their non-native status.  If  you 
modify the distribution parameters and wish to visualize the revised PDF curve, click the Refresh plot 
button. Left-clicking the plot will toggle between a PDF curve and a CDF curve. Right-clicking the plot 
will present a context menu with additional options (e.g., saving or printing the plot). Note that the mean 
value in this dialog (and in the Probabilistic Manager Uncertainties table), must be identical to the value 
in the baseline input file to insure consistency when calculating the perturbation cases. A future version of 
PRODAF will relax this constraint.   

At the conclusion of editing this dialog, either cancel the modifications or click the Accept changes 
button to transfer its contents back to the Probabilistic Manager dialog. Note that this action does not 
permanently alter the uncertainty definition. It merely allows the Probabilistic Manager to utilize it. To 
permanently save it, you must save the configuration file using the File > Save (or File > Save As…) 
menu within the Probabilistic Manager.   

A similar procedure is used to define the response variables (see Fig. 8.6). 

                  
  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

                     
4 Appendix B (Distribution Types) provides some suggestions for selecting an appropriate distribution type.  

Figure 8.6 – The Response Variable Definition dialog. 
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Probabilistic Manager options – To set user preferences for the Probabilistic Manager, select the Tools > 
Options menu item. This action will display the Preferences dialog as illustrated in Figure 8.7. 
 

 

The General tab handles the most common preferences:  

• Turn debug on - this option causes the system simulation execution and the FPI execution to 
pause after running so users may view the on-screen output – specifically, error messages to 
facilitate debugging   

• Turn ToolTips on – brief help messages appear whenever the mouse pointer hovers over a dialog 
control or menu item 

• Use both + and – perturbations - For many cases it is adequate to specify just a single 
perturbation (1 standard deviation about the mean value) of each of the N random variable to 
generate an adequate amount of probabilistic response data.  This requires a total of N+1 
simulation runs. Activating this + and - option causes both a positive and a negative perturbation 
to be run (a total of 2N+1 runs).  This option might be appropriate for skewed random variable 
distributions and quadratic response function modeling assuming the response function is highly 
non-linear.  Since the + and – perturbation option requires twice as much computational time, it is 
only recommended in cases where strong skewness and/or non-linearity is present.  

• Calculate confidence interval – Directs PRODAF to perform additional simulation code runs with 
random sets of uncertainties in the primary uncertainty parameters in preparation for running FPI 
multiple times. The number of random sample sets and other options are set in the CI tab. 
Activating this option will yield upper and lower confidence bounds in the CDF/PDF plots, but 
will increase the total execution time very dramatically.  

• Use NESSUS instead of FPI – Causes the NESSUS code to be used instead of FPI to perform the 
probabilistic analyses. This option requires that a NESSUS executable file be installed in the same 

Figure 8.7 – The Probabilistic Manager Preferences dialog  
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folder as FPI. Currently, there is no incentive for selecting this option unless the user has a version 
of NESSUS with enhanced capabilities relative to FPI.  

• Retain plots between runs - By default, whenever FPI is executed any existing results plots are 
erased before the new plots are displayed.  However, users may wish to retain previous plots to 
facilitate the comparison of results between FPI runs. This option permits the on-screen retention 
of previously generated CDF/PDF plots and sensitivities graphs. 

• Use COV instead of SD – The default uncertainty table contains a column that displays standard 
deviations (SD). Activating this option will cause the Probabilistic Manager to use the Coefficient 
of Variation (COV) parameter instead (COV = standard deviation/mean).   

• Skip FPI (use existing plot data) – Normally, if you click the Run FPI button, the Program 
Manager responds by invoking FPI to perform a probabilistic analysis. However, if a previous 
such invocation generated results data, that data persists until FPI is again run. If no changes are 
made to any of the FPI input data, then it is not necessary to rerun FPI just to visualize the results 
on-screen. Activating this option skips rerunning FPI in such cases, and just displays the 
previously generated probabilistic results. This option is not particularly helpful for problems that 
do not involve confidence interval calculations, but can be quite useful when the CI option is 
turned on and you want to avoid a lengthy recalculation of unchanged FPI data. 

• Sensitivity type/Probabilistic – Probabilistic sensitivity factors will be displayed in the sensitivity 
chart produced by FPI. These factors are essentially the deterministic sensitivities multiplied by 
the standard deviations and therefore give a better indication of the importance of the various 
uncertainties. The on-screen bar charts normalize these factors such that square root of the sum of 
their squares equals unity. 

• Sensitivity type/Deterministic – Traditional sensitivities (first derivatives at the MPP) will be 
displayed in the sensitivity chart produced by FPI. 

 
 
The FPI tab (Fig. 8.8) handles preferences that control the operation of the Fast Probabilistic Analysis 
code.  The default values are expected to be adequate for most problems, but more advanced users may 
prefer to modify these settings.    
 

 

Figure 8.8 – The FPI preferences dialog. 
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• Response model – This indicates how the response function will be modeled as a function of the 

random variables.  The choices are:  

 

1. Linear fit (linear model using data from the system simulation output) 
2. Quadratic fit (quadratic model using data from the system simulation output) 

 

Option 1 is adequate for many engineering problems.  Option 2 may be better if the random 
variable distributions are highly skewed and/or the response function is very non-linear.  

• Solution method – This option selects the method used to solve the probability problem.  The 
choices are:       

1. First-order (FORM) 
2. Advanced first order (FPI) 
3. Fast convolution in x-space (CONVX) 

 

It is suggested that new users use option 2 (the default) unless they are familiar with the other 
options as described in the FPI manual (ref. 3). In most cases, the results will hardly be affected by 
this choice.  

• Analysis type – This option indicates how the specific CDF values are determined:    

1. FPI defined probability levels (no user input, FPI selects values) 
2. User-defined response function levels (a list of response variable values is input) 
3. User-defined probability levels (a list of CDF values is input in the table) 

 

While options 1 and 2 are quicker to execute, option 3 is usually preferred since it allows the user 
to     tailor the calculated points to obtain smooth and accurate CDF/PDF curves especially in the 
tail regions.  A recommended set of CDF values for option 3 is: 
 

          0.001           0.8 
          0.01             0.9 
          0.05             0.95 
          0.1               0.99  

0.2               0.999  
0.5     

It is best to avoid inserting too many points in the middle section (i.e., 0.3-0.7) since a little 
computational scatter in this region for non-normal distributions can lead to some false jaggedness 
in the PDF curve.   

• Output quantity – FPI yields several output files to enable users to monitor its progress. The 
primary output file is displayed on-screen during execution and it can yield either a brief summary 
(short output option) or a more detailed output description (long output option). Note that since 
FPI executes rapidly, viewing this output during execution is not generally possible since the 
output scrolls by quickly. It may be easily viewed by turning on the Debug option which pauses 
the display just after execution. Alternatively, the FPI.mov file may be examined post-execution. 

 
 
The CI tab (Fig. 8.9) handles Confidence Interval preferences (described in the following section): 
 
• Number of random samples – The number of random samples of the uncertainty parameters. 

Each sample consists of a set of random values -- one for each of the primary uncertainty 
parameters designated as being uncertain. Typically, the user will request an upper bound of the 
95th percentile and a lower bound of the 5th percentile. To estimate these bounds using random 
samples, it is recommended that at least 30 samples (and preferably 100 or more) be generated.  
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Choosing a reasonable number is a classic tradeoff of computational speed versus accuracy since 
N samples will require N probabilistic analyses (instead of just 1 for problems without confidence 
intervals).    

• Lower percentile –  The value for the lower CI bound (default: 0.05). 
• Upper percentile –  The value for the upper CI bound (default: 0.95). 
 

 
 
Confidence Intervals – In many probabilistic problems it is difficult to obtain the required statistical 
parameters used to characterize uncertainties. This is frequently the case when investigating new concepts 
or advanced technologies since little, if any, relevant empirical (or even analytical) statistical data exists. 
In such cases, users are forced to estimate or guess values that they believe are reasonable. However, this 
means that there is uncertainty about the uncertainties and it is desirable to be able to indicate the degree 
of confidence in the resulting CDF and PDF curves. This may be accomplished in PRODAF using 
confidence interval determination techniques that 
are described in the companion PRODAF 
Theoretical Manual (Ref. 1).  To include 
confidence interval determination, users must 
provide additional information to characterize the 
uncertainty in some or all of the primary 
uncertainty parameters.  Determining confidence 
intervals requires a substantial increase in 
computational time since many more simulation 
code invocations (and FPI invocations) are 
required. The result is a pair of auxiliary CDF 
curves that bound the baseline CDF curve as 
illustrated by the green band in Figure 8.10. The 
red curve is the traditional CDF curve based on the 
expected uncertainty parameters, and the two 
dashed blue curves represent the upper and lower 
limits (typically the 5 and 95 percentiles) of the 
CDF determined by the uncertainties in the Figure 8.10 – Adding confidence intervals to CDF 

plots. 

Figure 8.9 – The Confidence Interval  preferences dialog. 
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uncertainty parameters. Such a plot can reveal to designers and managers how much variation might 
occur in the system-level merit criterion due to not knowing the uncertainties with definiteness.  
 
Three methods are offered to characterize the confidence interval uncertainties: 
 

• Users may specify the distribution type and supply the concomitant parameters 
 

• Users may provide a set of test data and PRODAF will determine both a suitable Beta distribution 
type and its parameters   

 
• Users may provide a set of test data and PRODAF will determine both a suitable Johnson 

distribution type and its parameters   
 

To request confidence interval computations, you must check the Calculate confidence intervals option 
in the Preferences dialog (Figure 8.7). You must also characterize the uncertainty in each of the primary 
uncertainty parameters of interest (it is not necessary to assign an uncertainty to every primary 
uncertainty, you choose which ones will be included in the confidence interval calculation). To 
accomplish this, select a primary uncertainty and display its Uncertainty Definition dialog (Fig. 8.5).  
Then click on the Define confidence parameters … button which will display the “Parameter 
Uncertainty” dialog (Fig. 8.11).  Then choose which of the above three methods should be used to 

Figure 8.11 – The Parameter Uncertainty dialog is used to describe uncertainty in the 
primary uncertainty parameters. 
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characterize the primary parameter uncertainty. If the first method is chosen, fill the edit boxes in the 
lower section with the required additional information. A PDF plot will be presented to visualize your 
data. Repeat this procedure for each of the primary uncertainty parameters (as many as 4, depending on 
the distribution type).  If the second method is chosen, you supply a file name containing the test data and 
PRODAF will fit a Beta distribution to the data. If the third method is chosen, you supply a file name 
containing the test data and PRODAF will fit a 4-parameter Johnson distribution to the data. Finally, 
dismiss the dialog using the Accept changes button.   
 
Any editing of the confidence interval data will only be permanently saved if you select Save from the 
File menu on the main Probabilistic Manager window.  
 
Once all of this additional information is defined and you have dismissed these auxiliary input dialogs, 
you may proceed to generate the confidence intervals. First, click on the Run Simulation button to 
generate the statistical response function values and then on the Run FPI button to perform a sequence of 
probabilistic analyses -- one for each of the N random uncertainty parameter samples. 
 
Progress status and terminating a process –  The execution times of simulation codes under the control of 
the Probabilistic Manager as well as the Optimization Manager described later are often lengthy. If the 
user detects that the execution is not proceeding properly, he may wish to terminate the entire process to 
avoid wasting time. This issue is accentuated by the repetitive invocations of codes.  Hence PRODAF 
provides a current status indication (Figure 8.12) during lengthy execution sequences and an Abort button 
to terminate the entire procedure. The Abort button may need to be clicked several times during 
execution of a fast-running code.  (The Abort button window must be active in order to register the click, 
and it may not be if a fast-running code is starting and stopping very quickly.) 
 
    

Figure 8.12- Execution progress dialog with Abort button. 
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9.0  Executing the Design Process 
 
PRODAF offers several operational modes involving design process simulation: 
 
• The design process may be executed once using the Single Design Point Manager and the current 

set of design variable values. 
 
• The design space may be explored parametrically using the Parametric Manager.  The exploration 

may be carried out directly by a sequence of design process invocations, or it may be carried out 
utilizing a response surface approximation to gain speed with some sacrifice in accuracy. 

 
• An optimum design point search may be initiated via the Optimization Manager.  

 
• A Most Probable Point (MPP) search may be initiated via the MPP Search Manager. 

 
All of these options are selected from the Designs menu as illustrated in Figure 9.1. 
 
  
 
 
 
 
 
 
 
Each of these design modes is described in detail in the sections that follow. The Define a new design 
process selection clears the Design Process Manager window in preparation for the user to define a new 
process. 
 

Figure 9.1 – The Designs menu 
used to select the type of analysis 
to be performed. 
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10.0  Single Design Point Calculation  
 
This is the simplest of the design mode options. It involves just a single design simulation; namely at the 
design point identified in the Single Design Point Manager dialog as shown in Figure 10.1.  The design 
process in this example is also very simple as shown in Figure EDP-2.  It consists of the engine 
performance modeling code NEPP transmitting its output file to an airplane sizing/optimization code 
FLOPS via the NEPP_FLOPS interface code 
(represented by the green circle).  There are two 
NEPP design variables, fan pressure ratio (FPR) and 
compressor pressure ratio (CPR), and tree FLOPS 
design variables (wing loading, wing aspect ration, 
and wing leading edge sweep angle).  These 5 design variables are listed in the design variable table along 
with their parent codes and design point values. Clicking the Execute button will initiate the design 
evaluation procedure which begins with a validation check of the execution sequence. That is, PRODAF 
will hunt for each required code and interface to ensure it is available. If the validity check is successful, 
the design process will proceed and the resulting response function value will appear in the lower right-
hand corner.  If the validity check fails, the execution sequence dialog will be displayed in order to 
identify the missing element(s), see Figure 10.3. The execution sequence dialog will be displayed 

Figure 10.2 – A simple 3-element design process. 

Figure 10.1 – The Single Point Design Manager dialog with 5 design variables illustrated. 
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unconditionally if the Display execution 
sequence dialog box is checked.  It is 
generally a good idea to examine this 
execution sequence once when the 
problem is first formulated, and then it 
may be deactivated if there are no 
configuration issues.  
 
The design variables may be modified by 
double-clicking their lines in the Single 
Design Point Manager table, an action 
that displays the design variable 
definition dialog (Figure 10.4) that is 
self-explanatory. Changes made while 
using the Single Design Point Manager 
will not persist unless the user selects File > Save from the menu.   
 
 

Figure 10.4 – The 
design variable 
definition dialog. 

Figure 10.3 – The Code Execution Sequence  dialog. 
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11.0  Parametric Design Space Exploration 
 
Sometimes it is desirable to explore design spaces parametrically to gain an understanding of the 
importance of the various design variables. A parametric exploration tool is available within PRODAF to 
perform such design space explorations and it is controlled by the Parametric Manager dialog (Fig. 11.1) 
and is invoked via the Designs > Explore the design space menu item.      
 
In this example a response surface was generated to parametrically explore the design space for the same 
airplane design problem defined above using the NEPP and FLOPS codes. The response surface 
coefficients are listed in the right-hand column after execution is completed.    
 

 

Figure 11.1 – The Parametric Manager tool with an airplane design problem example.   In this example a 
response surface was generated to parametrically explore the design space. The response surface 
coefficients are listed in the right-hand column. Five points per variable were generated. 
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The options for performing a parametric design exploration are: 
 
• Display execution sequence dialog - Activating this option causes PRODAF to unconditionally 

display a table listing the simulation codes and interfaces to be called in the proper order. If any 
codes or interfaces cannot be located, they are flagged as errors. This table will be displayed if 
there are any errors, irregardless of this setting.  Default: unchecked. 

• Use response surface methodology – If checked, this instructs PRODAF to create and use 
response surfaces to accelerate the parametric exploration procedure.  Default: unchecked.  

• Include cross terms  - If checked, the quadratic response surface model will include cross terms 
(e.g., cx1x2) in addition to the standard linear (cx1) and squared terms (cx1

2). Including cross terms 
increases execution time substantially – the number of function evaluations increases from (2n+1) 
to (2n+1) + ½ n (n-1) where n is the number of variables. Nevertheless, cross terms can be 
important for some problems, so it is recommended to select this option if an inaccurate response 
surface is encountered. Default: unchecked. 

• Check accuracy of response surface – This option causes PRODAF to check the accuracy of the 
response surface by performing N function evaluations for each design variable and comparing the 
result with the response surface result. This comparison table may be viewed by clicking the Show 
results button that appears after the parametric exploration is complete. Extra function evaluations 
are required to perform this option.  Default: unchecked.      

• Number of points to generate (and bounds) – This sets the number of points N to be generated for 
each design variable on the interval defined in the bottom of the Design variable data dialog (see 
snippet in Figure 11.2 below).  This dialog is invoked by double-clicking an item in the design 
variable table.  Default: 5.   

• Show debug log – This button is only visible after a parametric exploration is completed. It 
displays the history of the parametric procedure and may or may not be very useful to users since 
it mostly contains coding data.  

• Show results – Displays a summary of the parametric exploration. If the response surface option 
was selected, the summary also includes the RS coefficients. And if the check accuracy option was 
also requested, it includes the accuracy comparison. For the example displayed in Figure 11.1, the 
results file is listed below in Table 1. 

 

Modifications made in the Parametric Manager do not persist unless the File > Save menu item is 
activated.  

 

Figure 11.2 – Setting the upper and lower bounds of each design variable for a 
parametric analysis using the ”Design variable data” dialog. Only the bottom 
portion of this dialog is shown here – the top portion is the same as Figure EDP-
4.    
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Table 1 – Example results tabulation for the airplane design problem illustrated in PM-1. 

 
 

The response surface coefficients are: 

 1.84584 1.66958 -0.394889 -0.0814713 -0.447186 -0.11747 0.271546 0.00912558  
 0.000251953 0.0253099 0.00240883 

The actual function values and RS values are compared below. 

      x[1]       x[2]       x[3]       x[4]       x[5]       y        y-RS     error 
       1.4       20.4        110          8         32    8.67647    8.70580  0.0034 
      1.45       20.4        110          8         32    8.61581    8.58363  0.0037 
       1.5       20.4        110          8         32    8.49037    8.46010  0.0036 
      1.55       20.4        110          8         32    8.35692    8.33521  0.0026 
       1.6       20.4        110          8         32    8.20273    8.20896  0.0008 
 
       1.5         15        110          8         32    8.23355    8.07214  0.0196 
       1.5       17.5        110          8         32    8.38851    8.31791  0.0084 
       1.5         20        110          8         32    8.47574    8.44961  0.0031 
       1.5       22.5        110          8         32    8.53527    8.46724  0.0080 
       1.5         25        110          8         32    8.56095    8.37080  0.0222 
 
       1.5       20.4        100          8         32    8.20975    8.17449  0.0043 
       1.5       20.4        115          8         32    8.60494    8.58401  0.0024 
       1.5       20.4        130          8         32    8.87637    8.88015  0.0004 
       1.5       20.4        145          8         32    9.02213    9.06291  0.0045 
       1.5       20.4        160          8         32    9.12515    9.13229  0.0008 
 
       1.5       20.4        110          5         32    7.92629    8.10563  0.0226 
       1.5       20.4        110       6.75         32    8.36453    8.36777  0.0004 
       1.5       20.4        110        8.5         32    8.49147    8.47488  0.0020 
       1.5       20.4        110      10.25         32    8.36406    8.42698  0.0075 
       1.5       20.4        110         12         32    8.00918    8.22405  0.0268 
 
       1.5       20.4        110          8         20    8.55718    8.55357  0.0004 
       1.5       20.4        110          8         25    8.59547    8.59893  0.0004 
       1.5       20.4        110          8         30    8.56482    8.52385  0.0048 
       1.5       20.4        110          8         35    8.33946    8.32833  0.0013 
       1.5       20.4        110          8         40    7.95272    8.01237  0.0075 
 
The RMS error of the RS = 0.009972 
 
 Execution time: 
    0 hours, 1 minutes, 54 seconds 

 



   31 

Figure 12.1 – Optimal symmetric Latin hypercubes are used to obtain a good design 
space sample to create a response surface.   

12.0  Design Point Optimization 
 
As one option, PRODAF offers traditional design point optimization (i.e., typically, a lengthy series of 
accurate but time-consuming function evaluations). However, some physics-based modeling codes 
involve such lengthy calculations that traditional brute-force methods are too slow. So it is important to 
also implement a much faster although approximate approach to modeling the design space in such 
situations. Response surface modeling is an attractive  technique for such situations provided its fidelity is 
reasonably accurate. An efficient response 
surface technique to locate optimal design 
points is implemented in PRODAF.  This 
technique employs an optimal 
symmetric Latin hypercube 
algorithm to select the points 
used to construct the 
response surface (Fig. 
12.1). Another 
acceleration 
technique is to 
employ a global-
local search 
algorithm in which the 
response surface search 
is limited to a relatively 
small local region called 
a “trust region” instead 
of the entire design space. Then successively smaller local searches are carried out until the optimum is 
found.  
 
A sequential quadratic programming (SQP) method is used to locate the optimum within each trust 
region. That is, the problem is to: 
 
                        minimize  f(x)   
 
    subject to 
 
                   g(x) = √x·xT    = 0 
                   xlower  ≤   x  ≤  xupper 
 
where x is the design variable vector with upper and lower bounds, and f(x) is a user-specified response 
function such as weight, cost, performance, or failure probability. The details of these adaptive search 
methodologies are contained in Reference 1.  
 
The PRODAF code implements these algorithms in a general way; that is, the user may select the function 
evaluation code, identify and characterize the design variables, and select values for the optimization 
control parameters via the Optimization Manager as shown in Figure 12.2. This tool is launched by 
selecting Design > Optimize a design from the main menu.  
 
In the example problem illustrated in Figure 12.2, two codes plus a data transfer interface comprise the 
simulation. The NEPP code models the performance of a turbofan engine and its output file is reformatted 
by an interface before sending it to the airplane performance and sizing code FLOPS.  For a fixed payload 
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and mission profile, FLOPS computes many merit criteria such as takeoff gross weight, fuel burned, 
airplane cost, and return on investment. Here, we chose return on investment as the response variable and 
selected 2 engine design variables (fan pressure ratio and compressor pressure ratio) and 3 airframe 
design variables (wing loading, wing aspect ratio, and leading edge wing sweep angle) to be optimized. 
The design variable initial values and upper/lower bounds are listed in the design variable table. These 
values are edited using a slightly modified form of the Design Variable Data dialog (Figs. 10-4 and 12.3). 
The leftmost checkmarks indicate which of the listed variable will be active during the optimization (all 5 
in this example).  

Figure 12.3 – Setting the initial value and the upper and lower bounds  for each design 
variable for optimization problems  using the lower portion of the ”Design variable data” 
dialog. The upper potion of this dialog is the same as displayed in Figure10.4.  
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Optimization is initiated by clicking the Perform optimization button. If a solution is successfully 
obtained, the optimum design variable values will appear in the rightmost table column (this column is 
blank initially) and the response function value will be displayed in the solution summary  the lower 
right-hand corner. 

Several options are available to control the optimization process: 

• Maximum iterations – This value is a limit on the number of  local trust region searches to allow. 
Each search within a trust region is counted as an iteration. Default: 10. 

• Number of Latin Hypercube samples – This value specifies how many random Latin hypercube 
samples will be used during the construction of response surfaces. The best sample (optimum 
symmetric hypercube) will be used to select the design space values to construct response 
surfaces.  See Reference 1 for more details. Default: 30. 

• Convergence tolerance – This value sets the criteria for a successful solution. The ratio of the 
difference between successive iteration RMS x-vector values divided by the current RMS x-vector 
value must be less than the tolerance to declare convergence. The x-vector is composed of the 
design variables.  Ideally, it is desirable to set this tolerance quite small to ensure accuracy.  
However, many simulation codes involve too much numerical noise to set this value tightly.  
Default: 0.001.       

Figure 12.2 – Optimization Manager dialog. Design point optimization example. Airplane return on investment 
merit criterion and 5 design variables (2 in NEPP code and 3 in FLOPS code).   
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• Display execution sequence dialog – Activating this option causes PRODAF to unconditionally 
display a table listing the simulation codes and interfaces to be called in the proper order. If any 
codes or interfaces cannot be located, they are flagged as errors. This table will be displayed if 
there are any errors, irregardless of this setting.  Default: unchecked. 

• Use response surface methodology – If checked, this instructs PRODAF to create and use a 
response surface(s) to accelerate the optimization procedure. This option is recommended for most 
problems.  Once the optimization procedure is completed using a response surface, a final 
calculation is made without the response surface  to yield a more accurate response value.  
Default: unchecked.  

• Include cross terms  - If checked, the quadratic response surface model will include cross terms 
(e.g., cx1x2) in addition to the standard linear (cx1) and squared terms (cx1

2). Including cross terms 
increases execution time substantially. But cross terms can be important for some problems, so it 
is recommended to try this option if convergence difficulty is encountered. Default: unchecked. 

• Show debug log – This button is only visible after an optimization is completed. It displays a 
debug log of the optimization procedure and might be useful when encountering convergence 
difficulties.  

• Function to optimize – A drop down list of merit criteria to select from.  The list may be edited 
using the Add, Modify, and Delete buttons. The Add and Modify buttons trigger the Response 
Function Definition dialog (Figure PM-6) that is self-explanatory.     

• Design variable Add, Modify, Delete buttons – These enable design variable editing. The Add 
and Modify buttons display the Design variable data dialog that is discussed above (see Fig. 
EDP-4), but augmented with additional entries for the lower and upper bounds, and the initial 
value (Figure DPO-3).  Double-clicking a line in the design variable table will also display this 
dialog.      

 
Changes made while using the Optimization Manager will not persist unless the user selects File > Save 
from the menu.   
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13.0  Most Probable Point (MPP) Search Manager 
 
PRODAF facilitates searching for the Most Probable Point (MPP) for optimization problems involving 
uncertainties. To perform this function efficiently, it utilizes both the Optimum Symmetric Hypercube 
sampling technique and the adaptive response surface methodology described above in the Optimization 
Manager section. It is invoked from the Design > MPP search menu which displays the dialog shown in 
Figure 15.1.  This dialog is very similar to the Optimization Manager dialog, but includes two additional 
columns in the design variable table; namely, Mean and SD to characterize the uncertainties. Double-
clicking an item in the design variable table (or clicking the Modify button after highlighting an item) 
displays the standard Design variable data dialog, but includes additional items in the Value(s) for this 
variable section (see Fig. 15.2).  The Initial trust size parameter bounds the size of the initial trust region 
used in the adaptive search procedure.   
 
 

 
 
 

Figure 15.1 – The MPP Search Manager dialog  illustrated with an analytic cubic expression  y = x1
3 + x2

3 - 18.  
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The cubic example problem illustrated in Figure 15.1 is the same problem described in Reference 1. 
Although it is a simple analytic expression, it does not usually converge using traditional optimization 
techniques, but does so readily using the progressively smaller trust region approach in conjunction with 
response surface representation. 

Several options are available to control the optimization process: 

• Maximum iterations – This value is a limit on the number of  local trust region searches to allow. 
Each search within a trust region is counted as an iteration. Default: 10. 

• Number of Latin Hypercube samples – This value specifies how many random Latin hypercube 
samples will be used during the construction of response surfaces. The best sample (optimum 
symmetric hypercube) will be used to select the design space values to construct response 
surfaces.  See Reference 1 for more details. Default: 30. 

• Convergence tolerance – This value sets the criteria for a successful solution. The ratio of the 
difference between successive iteration RMS u-vector of design values divided by the current 
RMS u-vector value must be less than the tolerance to declare convergence. The u-vector is the x-
vector of design variables transformed into standard normal space.  Ideally, it is desirable to set 
this tolerance quite small to ensure accuracy.  However, many simulation codes involve too much 
numerical noise to set this value tightly.  Default: 0.001.       

• Display execution sequence dialog – Activating this option causes PRODAF to unconditionally 
display a table listing the simulation codes and interfaces to be called in the proper order. If any 
codes or interfaces cannot be located, they are flagged as errors. This table will be displayed if 
there are any errors, irregardless of this setting.  Default: unchecked. 

• Use response surface methodology – If checked, this instructs PRODAF to create and use a 
response surface(s) to accelerate the optimization procedure. This option is recommended for most 
problems.  Once the optimization procedure is completed using a response surface, a final 
calculation is made without the response surface  to yield a more accurate response value.  
Default: unchecked.  

• Include cross terms  - If checked, the quadratic response surface model will include cross terms 
(e.g., cx1x2) in addition to the standard linear (cx1) and squared terms (cx1

2). Including cross terms 
increases execution time substantially. But cross terms can be important for some problems, so it 
is recommended to try this option if convergence difficulty is encountered. Default: unchecked. 

• Show iteration history/Show debug log – These 2 buttons are only visible after a search is 
completed. They display the history of the search procedure and a debug log.  

Figure 15.2 – Setting the values associated with each design variable for MPP 
problems using the lower portion of the ”Design variable data” dialog. The upper 
potion of this dialog is the same as displayed in Figure 10.4.  
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• Function to optimize – A drop down list of merit criteria to select from.  The list may be edited 
using the Add, Modify, and Delete buttons. The Add and Modify buttons trigger the Response 
Function Definition dialog (Figure 8.6) that is self-explanatory.     

• Design variable Add, Modify, Delete buttons – These enable design variable editing. The Add 
and Modify buttons display the Design variable data dialog that is discussed above (see Fig. 
10.4), but augmented with additional entries (Fig. 15.2).  Double-clicking a line in the design 
variable table will also display this dialog.      

 
Changes made while using the MPP Search Manager will not persist unless the user selects File > Save 
from the menu.   
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14.0  Data Interfaces Between Codes 
Although PRODAF establishes a framework to enable probabilistic design processes that involve a 
sequence of user-defined simulation codes, a dilemma still exists; namely, how to implement a 
mechanism to transfer data between the codes. Whenever the user requests a design process simulation, 
PRODAF first checks to make sure all of the interfaces are available before initiating the simulation.  If 
any modeling, analysis, or interface codes are missing, PRODAF advises the user of the missing elements 
and halts. Since PRODAF is a generic framework that permits a wide range of user-specified codes and 
each code pair requires a unique interface, PRODAF cannot provide a generic code-to-code  data transfer 
interface. These interfaces are code-specific and must either be acquired externally or written by the user. 
However, a tool is 
provided by 
PRODAF to help 
users setup the data 
transfer linkages 
(Figure 14.1). In the 
case illustrated, data 
is to be transferred 
from the NPSS code5 
to the FLOPS code 
through an interface 
code entitled 
NPSS_FLOPS.exe. 
NPSS produces an 
output file called 
output.FLOPS that 
the interface code 
reformats into an acceptable FLOPS input file entitled EngineDeck.flops. This tool will run when the user 
selects Tools > Interface editor from the main menu. All interfaces supplied by the user must be located 
in the “Interfaces” folder within the PRODAF installation directory. 

In some cases these interfaces will be relatively easy to implement with straightforward scripts. In fact, 
some robust codes such as ANSYS have their own script building facility that obviates the need for a 
separate PRODAF interface. But in other cases the interfaces will be more challenging. Simulation codes 
that are entirely encapsulated such that all input and output are implemented through a GUI are 
particularly difficult to integrate into PRODAF. QRAS 1.7 provides an example of a difficult code to 
interface since it is driven through a GUI only (e.g., no provision for user-defined input files). However, 
since it does archive the GUI-generated data in an undocumented binary database, a “backdoor” approach 
can be used to create an interface.   

The QRAS Database Interface is a tool that harvests probabilistic component reliability data embedded in 
FPI or CALCE6 output files, displays failure probabilities, and incorporates the failure probability data 
into the system-level QRAS binary database files (see Figure 14.2). In the example shown, 3 CALCE 
electronic components and 2 FPI mechanical components are represented.  The FPI data files have a 

                     
5   NPSS is an engine performance modeling code that handles arbitrary turbine engine or rocket engine 
configurations.  FLOPS is an aircraft sizing/optimization code with cost estimation capability.  
6 CALCE is a physics-based electronic circuit board probabilistic reliability code  

Figure 14.1 – The Interface Database Editor helps users setup the data transfer 
mechanism that connects codes. 
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*.mov file name extension while the CALCE data files have a *.rent extension.  This tool can invoke 
NESTEM, CALCE, and QRAS directly, as an alternative to invoking them from the Design Process 
Manager. The columns with headings “Phase”, “Start time”, and “End time” contain mission duty 
cycle data associated with the predicted failure probabilities. 

To use this interface, users must list the components in the table along with several phase and time 
parameters that are expected by QRAS, and the name of the output file containing the failure rates (or 
reliabilities).   This is done with the editing boxes underneath the table and the editing buttons in the 
lower right-hand corner.  The QRAS Database Interface is invoked from the Tools > QRAS Database 
Interface main window. 
 

 

Figure 14.2 – QRAS Database Interface dialog. 
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15.0  Progressive Failure Analysis 
 
Failure processes for complex structural systems frequently involve more than just a single component 
failure. Rather, a sequence of  several component failures eventually lead to a catastrophic system-level 
failure. Analyzing such progressive failure processes is not straightforward and can easily require 
inordinate amounts of computational effort. In recent years, advanced methods have been developed to 
handle such problems (e.g., composite structures) more efficiently without sacrificing essential accuracy.  
PRODAF offers an advanced progressive failure methodology based on a fast branch and bound search 
procedure. System failure probability is computed using the dominant failure sequence to attain 
computational efficiency. The methodology is detailed in the companion PRODAF Theoretical Manual 
(Ref. 1). To illustrate, consider a 4-component structure whose analysis process for structural integrity 
can be represented as depicted in Figure 15.1.  The 4 components (Item 1 through Item 4) are modeled by 
ANSYS and their failure probabilities are determined by NESSUS. The entire structure failure probability 
is subsequently calculated by QRAS.  PRODAF will first utilize this process definition to determine the 
failure probabilities of the 4 components with an intact structure (no failed components). Then it will 
reanalyze the system assuming the “weakest link” component has failed and repeat this process until the 
entire structural system fails. At each step of this procedure, it will also determine the failure probabilities 
of other failure sequences and retain all sequences that have a failure probability above a cutoff  value.  
The cutoff value is based on a fraction of the first set of failure probabilities and its default value is 0.5. 
This limits the number of sequences that need to be analyzed. At the conclusion of this procedure, the 
overall failure probability is influenced by all of the significant failure sequences as explained in 
Reference 1.          
 

 

Figure 15.1 – PRODAF representation of the progressive failure process of a 4-component structure. 
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To initiate the PRODAF Progressive Failure Manager tool, select Tools > Progressive failure from the 
main menu (Figure 15.2).  This dialog enumerates the structural components, the code used to determine 
its failure probability, the corresponding input and output files names, and the keyword used to harvest 
the failure probability Pf  from the output file.  You may edit any of these values by right-clicking any 
entry in this table to open an editing box.  To add new components, right-click items in the first blank 
line. To save your changes, select the menu item File > Save.   

 
The cutoff value may also be modified. The Dominant failure sequences table will be blank until the 
Execute button is clicked to commence the branch and bound calculation procedure described in 
Reference 1. Clicking this button starts the progressive failure analysis and populates this table in the 
order of most likely to least likely failure sequences. In general, this will be a lengthy execution process 
since a series of finite element analyses are likely to be needed. Upon completion, the Overall system 
results section will appear in the lower right-hand corner. The failure probability and reliability values 
reported there account for the ensemble of dominant failure sequences. Clicking the Show log button will 

Figure 15.2 – The Progressive Failure Manager dialog. 
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display a history of each failure sequence evaluated. The debug log is also available, but is not likely to be 
of value to most users.  
 
Since, PRODAF does not know how to model the series of structural problems required in this procedure, 
the user must supply a code that takes the PRODAF-determined failure sequences and reformulates the 
structural input for the structural analysis code he chooses to calculate failure probabilities.  The name of 
the user-supplied code must be ConditionalFailProb and it must accept one argument in the calling 
statement; namely, the failure sequence formatted as a comma-separated string such as “2,4,1,0,”.  
Furthermore, it must create a 1-line text output file named PfResult that contains the resulting failure 
probability. PRODAF will subsequently read that Pf  value.  This data transfer process is illustrated in 
Figure 15.3 and Appendix D contains an example ConditionalFailProb code.   
 

  

Figure 15.3 – Data flow during a progressive failure analysis. 
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16.0  Online Help System 

Two online help systems are available in PRODAF.  One is the implementation of ToolTips – brief 
messages that define the purpose of dialog controls. These tips appear automatically whenever the mouse 
point hovers over a control.  ToolTips can be disabled if desired via the Preferences dialog that is 
available from the Probabilistic Manager’s  Tools > Options menu.  

The other online help system is more robust and is activated via the Help menu on either the main 
PRODAF window or the Probabilistic Manger window, or by pressing F1 on the keyboard.  An example 
help window is displayed in Figure 16.1.  

In addition to these two online help systems, a third type of help is implemented in the form of popup 
dialogs that inform users of error conditions and possible remedies. There are dozens of such error 
message popups. Figure 16.2 illustrates one of the more elaborate ones. This one occurs if the user 
attempts to run FPI without previously generating all of the required perturbation data via simulation 
runs. On the left it displays the list of random variables in the simulation database and on the right it 
displays the list of random variables that FPI needs.  The right-hand list is missing 4 variables 
(highlighted in blue). The suggested solution to resolve this mismatch is posted in the text above the two 
lists.  

Figure 16.1 – Example online help window. 



   44 

  
 
 
 
 

Figure 16.2 – Example help error message popup dialog. The 4 highlighted 
entries in the FPI request list (right side) are missing in the simulation database 
(left side).  Hence FPI cannot run this case until the user either reruns the 
simulation sequence again or inactivates the 4 missing items in the FPI request.  
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17.0  Utility Tools 
 

Random data sampling – Sometimes it is necessary to generate a set of random values for a given 
distribution type (e.g., in order to perform a random test series).  A tool to do this may be invoked either 
from PRODAF’s main menu or the menu within the Probabilistic Manager dialog (menu: Tools > Data 
sampling).  Figure 17.1 illustrates this tool for a Weibull distribution and 25 random values. In this 
example the user specified the native Weibull distribution parameters (α and β) and the tool displayed the 
equivalent mean and standard deviation.  Alternatively, the mean and standard deviation could have been 
input.   
  
The Generate random samples button will generate a new set of samples each time it is clicked. Double 
clicking the plot will toggle between a PDF curve  and a CDF curve.  The user specifies the distribution 
type and its parameters using the input controls in the upper left portion of the dialog.  Users also specify 
the number of samples to be generated and whether or not to sort the samples.    

Figure 17.1 –User interface for the tool that generates and displays random samples for a 
specified distribution. A text file (DistributionPoints) is also created that lists the random 
samples.  
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Database viewer – Some advanced users may wish to inspect binary databases that are used in 
conjunction with their codes.  QRAS 1.7 is one such example code since understanding its internal 
structure is necessary in order to modify its reliability data.  The Database Viewer tool provides this 
capability.  It is invoked using the Tools > Database viewer menu selection on the main PRODAF 
window.  Figure 17.2 illustrates its usage for the problem depicted above in Figure 14.2. After selecting a 
database and a specific table within the database, the viewer will display the table contents in the lower 
section. Queries may also be performed using the Query Text editing box. Doing so requires a knowledge 
of SQL (Structured Query Language), however.   
 
 

Note that using this viewer requires registering a specific database using Window’s Control Panel’s 
ODBC Data Source Administrator (Fig. 17.3). On the User DSN tab, select Add to bring up a database 
format selector (Fig. 17.4) and choose Microsoft Paradox Driver (*.db).  Select Finish and the ODBC 
Paradox Setup dialog will appear (Fig. 17.5). On this dialog, add a Data Source Name such as QRAS 1.7 
(and a description if you prefer) and click the Select directory … button to navigate to the folder in 
which you have the QRAS database. Once this is done, you are finished registering the QRAS database 

Figure 17.2 – The Database Viewer using the 5-component QRAS 1.7 reliability example. The 
contents of  table EDSElems is displayed.   
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and the Database Viewer 
will now be able to use it. 
 
 
 
   

Figure 17.3 – The ODBC Data Source Administrator dialog. Choose Add to 
start the registering process.  

Figure 17.4 – Select Microsoft Paradox Driver (*.db) 
and then Finish. 

Figure 17.5 – Type in a Data Source Name and, 
optionally, a descriptor. Then click Select Directory… to 
navigate to the QRAS database location.  
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18.0  Example Problems 
 
Several relatively simple examples are presented here to demonstrate how to use PRODAF. The codes 
required to run each example are included in the PRODAF installation folder so users may run these on 
their own or use them as templates for other problems.  
 
18.1 Example 1 – Probabilistic analysis (delivering payload to orbit with a 1-stage launch vehicle). 
 
This example uses simple analytic expressions to estimate the amount of payload delivered to low-Earth 
orbit using a hypothetical single stage launch vehicle:   
  
 
 
 
 
 
 
              where, 
 
 
Here, the takeoff mass mtakeoff is assumed to be a fixed constant (5,000,000 lb.) and g0 is the gravitational 
constant. There are 5 input variables each of which is ascribed an uncertainty with a Frechet distribution: 
 
          

Variable Mean value COV 
Engine average specific impulse, Isp  390. 0.02 
Velocity increment, ΔV, ft/s 25750. 0.01 
Tankage/propellant mass ratio, mtankage  / mpropellant 0.03 0.10 
Structure ratio, mstructure / mtakeoff 0.05 0.03 
Engine mass ratio, mengine / mtakeoff 0.04 0.03 

 
 
To run this problem, start PRODAF and use the File/Open… menu to select the Launch vehicle.tre file. 
This will display both the Code Library Manager and the Design Process Manager (Figure 18.1.1):  

Now right-click the launch_vehicle icon in the Design Process Manager or the corresponding entry in the 
Code Library Manager, and select Run probabilistically. This action will display the Probabilistic 
Manager (see Fig. 8.4). Here you may edit the uncertainty parameters (double-click an entry in the 
Uncertainties table) or just proceed to run the simulation multiple times by clicking the Run Simulation 
button. Since there are 5 uncertainties, six simulations will be run (a baseline case plus 5 perturbation 
cases). Since this is a very simple model, this process takes less than a second to complete. Now click the 
Run FPI button to generate the CDF/PDF/sensitivity results using the previously generated perturbation 
data (Fig. 18.1.2): 

Figure 18.1.1 – The PRODAF windows for example 1. 
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Note that the CDF curve is initially presented. Double-clicking the plot will toggle between the CDF and 
PDF curves. The mean payload value is 61,570 lb. with a 34,370 lb. standard deviation. This is a 
relatively large standard deviation for such small COV values in the input variables. This occurs because 
the response function (payload) is very small compared to the takeoff mass, and very sensitive to the input 
variables. The other response function (propellant mass) is far less sensitive. To verify this, select 
Propellant mass (lb) under Response Variables and click Run FPI again.  You may save or print these 
plots using the context menu (right-click the plot). 
 
The sensitivities displayed in this example are the probabilistic sensitivity factors that include the 
magnitudes of uncertainties, not just the first derivatives as in deterministic analyses. If the traditional 
deterministic sensitivities are desired, use the Tools > Options menu to gain access to the Preferences 
dialog where this option is set. The deterministic sensitivity chart is quite different than the probabilistic 
sensitivity chart since the COV values vary substantially in this case.  
 
This example problem could also have invoked using the Probabilistic Manager icon instead of 
PRODAF, then selecting the Tools > Code database editor, and finally selecting the Launch_vehicle 
code.  

Figure 18.1.2 – 
Example 1 result 
charts produced 
by PRODAF. 
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18.2 Example 2 – Probabilistic analysis with confidence intervals. 
 
We will repeat Example 1, but this time we will include uncertainties in the primary uncertainty 
parameters for Isp and ΔV in order to determine confidence intervals in the results (CDF and PDF curves). 
 We could have accounted for similar uncertainties for the tankage, structure, and engine mass ratios but 
limited this example to just two in order to reduce the amount of additional function evaluations required. 
 We proceed just as we did in Example 1 but click on the Calculate confidence interval box on the 

Preferences dialog (invoked via the Tools > Options menu) before execution. Now click Run simulation 
and then Run FPI to yield the following CDF and PDF graphs: 
The red curves are the baseline curves that we generated in Example 1 that presume deterministic primary 
uncertainty parameter values. The blue curves represent the 5 and 95 percentiles of the large set of 
random values characterizing the uncertainties in the primary uncertainty parameters. The green region on 
the CDF plot is the confidence interval for a payload mass value of 75,000 pounds. This value may be 
altered by using the context dialog (Fig. 18.2.2) invoked by a right-click on the plot. For a full discussion 
of the calculation methodology, refer to the PRODAF Theoretical Manual (Ref. 1).  For details on how to 
configure the confidence interval procedure and modify the uncertainty values assumed, see the section 
above entitled “Confidence intervals.”   
 
With the current methodology, calculating confidence intervals requires approximately two orders of 
magnitude more function evaluations than without confidence intervals. Hence, this option and the 
variables that control it (mainly, the number of random samples to be used) must be selected with care.  
Methods to accelerate the procedure have been suggested, but have not yet been pursued.  
18.3 Example 3 – Design optimization involving two simulation codes (NEPP and FLOPS)7 
 

                     
7 Neither NEPP nor FLOPS are provided in the PRODAF installation folder since they are not in the public domain. 
 They are obtainable from NASA (see footnote 1 above for contact points). 

Figure 18.2.1 – CDF and PDF results for example 1with confidence intervals added. 

Figure 18.2.2 – Confidence interval options dialog. 
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This example illustrates optimizing a set of 5 design variables – 2 in one simulation code and 3 in 
another. In this instance, the NEPP code generates an engine performance dataset that is transmitted via 
an interface to the FLOPS code that sizes an airframe for a given mission (payload, range, cruise speed). 
In addition to determining the airplane size (takeoff gross weight and dimensions), it also estimates 
several economic criteria including return on investment (ROI) which we will assume as our response 
function for this example (Fig. 18.3.1):   
 

The five design variables are listed below along with their initial values and upper and lower bounds. 
 

Design Variable Code Initial 
value 

Minimum Maximum 

Engine fan pressure ratio (FPR) NEPP 1.5 1.4 1.6 
Engine compressor pressure ratio (CPR) NEPP 20.4 15. 25. 
Wing loading, lb/ft2 FLOPS 110. 100. 160. 
Wing aspect ratio FLOPS 8. 5. 12. 
Wing leading edge sweep angle, deg FLOPS 32. 20. 40. 

 
This problem requires the user to prepare an interface to transfer data from one of the NEPP output files 
to one of the FLOPS input files.  The interface in this case simply performs some minor file reformatting. 
It is named NEPP_to_FLOPS.exe and is located in the Interfaces folder.  After it was created (see 
Appendix E for the source code), it was inserted into the Interfaces folder using the Interface Database 
Editor (see Fig. 14.1) to make it accessible to PRODAF. You may invoke this editor via the Tools > 
Interface  editor menu selection. 
 
To run this example, select NEPPtoFLOPS.tre from the File > Open… menu.  This will populate the 
Design Process Manager with a NEPP box and a FLOPS box with an arrow  linking the two boxes that 
indicates the data flow direction (Fig. 18.3.2). There is also a green circle with the number 1 inside. The 
number indicates the execution sequence within the 
entire process, and in this simple case there is only one 
sequence (NEPP to FLOPS). The green color of the 
circle indicates that PRODAF found the required data 
transfer interface (located in the Interfaces folder). If 
instead the circle were colored yellow, it would signify 
that the interface was not found.  
 
Select Designs > Optimize design variables from the main menu to view the Optimization Manager as 
shown previously in Figure DPO-2. Clicking Perform optimization will initiate the optimization 

ROI 

NEPP code               Data Transfer Interface         FLOPS code 

Figure 18.3.1 – Data transfer from NEPP engine code to FLOPS airframe code to determine Return on Investment (ROI). 

Figure 18.3.2 – The Design Process Manager 
window for example 3. 
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procedure  (using response surface modeling since this option is checked).  When the optimization is 
complete, the solution vector is posted in the right-most column within the Design variables table and the 
response value posted in the results summary in the lower right-hand corner (Fig. 12.2). In this example, 
the optimum FPR is constrained to its lower limit (1.4) and the wing loading constrained to its upper limit 
(160). The maximum ROI attained is 9.57 percent. Only twelve function evaluations were required to 
obtain the solution since we opted to use the response surface method (11 evaluations to obtain the 11 RS 
coefficients, plus 1 final evaluation to yield a more accurate solution value).  
 
If this problem is repeated without using the response surface, the solution obtained is considerably 
different and less optimum than that obtained using the response surface method. Either a local optimum 
was isolated or numerical noise difficulties prevented the optimizer from finding the global optimum. 
Regardless of the cause, the response surface method tends to overcome these hazards.  Moreover, the 
number of function evaluations is 125, a factor of 10 greater than required using the response surface.  
Hence, this result supports the value of using the response surface method. 
 

Parameter Traditional Optimization Response Surface Optimization 
Number of function evaluations 125 12 
ROI solution value, percent 8.92 9.57 
Optimum fan pressure ratio 1.400 1.400 
Optimum compressor pressure 
ratio 

20.76 21.63 

Optimum wing loading, lb/ft2 117.3 160.00 
Optimum wing aspect ratio 8.39 8.83 
Optimum wing sweep angle, deg 20.00 24.38 

 
In case of doubt about the validity of the response surface solution, you might consider rerunning the 
problem using the Designs > Single design point evaluation menu option and using the response surface 
solution values.  This was done in this case and the response function value obtained (9.57) was identical 
to that obtained during the response surface method optimization. 
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18.4 Example 4 – Parametric design space exploration (quadratic function) 
 
An example of a parametric design space exploration for the Example 2 problem is illustrated in the 
section above entitled “Parametric Design Space Exploration”.  Since that example involves two codes 
not included in the PRODAF installation, two examples are presented here that may easily be replicated 
by users; namely, the quadratic functions: 
   
 
      Y1 = 1 + (x1-1)2 + 2(x2-2)2 + 3(x3 -3)2 + 4(x4-4)2 
  
and, 
      y2 = 1 + x12 + 2x22 + 3x32 + 4x42 + 5x2x3 + 6x1x4 
 
 
In both cases we limit the design space to the region : 
 

Variable Lower bound Upper bound 
x1 -1 10 

x2 1 100 

x3 1 10 

x4 2 4.5 

          
To run a parametric analysis for Y1, select File > Open… > Quadratic.tre from the main menu. This 
displays the following in the Design Process Manager window (Figure 18.4.1): 
 
 
 
 
 
 
 
 
Now select Designs > Parametric analysis from the menu to display the Parametric Manager. Limit 
values may be modified by double-clicking lines within the Design variables table to display the Design 
variable data dialog. Select the number of points you wish to generate for each variable in the edit box 
underneath this table.  Then click the Analyze button to initiate the parametric analysis. To see the 
parametric function values, click the Show results button that appears upon completion: 
 
            

Figure 18.4.1 – Example 4 
depicted on the Design 
Process Manager window. 

x[1]       x[2]       x[3]       x[4]       y 
        -1         50        3.5          3 4617.75000  
      1.75         50        3.5          3 4614.31250  
       4.5         50        3.5          3 4626.00000  
      7.25         50        3.5          3 4652.81250  
        10         50        3.5          3 4694.75000  
 
       1.5          1        3.5          3    8.00000  
       1.5      25.75        3.5          3 1134.12500  
       1.5       50.5        3.5          3 4710.50000  
       1.5      75.25        3.5          3 10737.12500  
       1.5        100        3.5          3 19214.00000  
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If you wish to fit a response surface to this region using the optimal symmetric Latin hypercube method, 
check the Use response surface methodology box before you click Analyze.  And if you also wish to 
check the accuracy of the response surface, check the Check accuracy of the response surface box.  As 
soon as the response surface is generated, its coefficients will be posted in the two right-most columns of 
the Design variables table (Figure 18.4.2). 

  

Figure 18.4.2 – Parametric Manager dialog for example 4. 

       1.5         50          1          3 4625.25000  
       1.5         50       3.25          3 4613.43750  
       1.5         50        5.5          3 4632.00000  
       1.5         50       7.75          3 4680.93750  
       1.5         50         10          3 4760.25000  
 
       1.5         50        3.5          2 4626.00000  
       1.5         50        3.5      2.625 4617.56250  
       1.5         50        3.5       3.25 4612.25000  
       1.5         50        3.5      3.875 4610.06250  
       1.5         50        3.5        4.5 4611.00000  
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The parametric results table will contain values generated by the response surface  (y-RS) as well as the 
normal function evaluation (y). An error column also appears (relative error) to check the accuracy of the 
response surface at various points: 

 
 
The second function Y2 presents a more challenging problem for the response surface method since it 
contains two cross terms.  It is executed in a similar fashion but using the using the quadratic-CT.tre 
configuration file instead of the quadratic.tre file at the beginning of the entire procedure.  In this case, 
the standard response surface (without cross terms) fails to accurately model the true response surface.  
Adding cross terms to the response surface model (by checking the Include cross terms box), however, 
rectifies the inaccuracy problem quite nicely – but at the expense of additional function evaluations. 
Hence, the necessity of including cross terms is problem dependent.  
 

  Excluding cross 
terms 

Including cross terms 

Normalized RMS error 6.90 0.000005 
Number of coefficients 9 15 
Number of function evaluations 29 35 

The response surface coefficients are: 
 
 101.001 -2.00026 -7.99955 -18.0068 -31.9956 1.00001 2 3.00064 3.99926 
 
The actual function values and RS values are compared below. 
 
      x[1]       x[2]       x[3]       x[4]       y        y-RS     error 
        -1         50        3.5          3 4617.75000 4617.75329  0.0000 
      1.75         50        3.5          3 4614.31250 4614.31511  0.0000 
       4.5         50        3.5          3 4626.00000 4626.00211  0.0000 
      7.25         50        3.5          3 4652.81250 4652.81427  0.0000 
        10         50        3.5          3 4694.75000 4694.75161  0.0000 
 
       1.5          1        3.5          3    8.00000    7.99120  0.0011 
       1.5      25.75        3.5          3 1134.12500 1134.12451  0.0000 
       1.5       50.5        3.5          3 4710.50000 4710.50268  0.0000 
       1.5      75.25        3.5          3 10737.1250 10737.1257  0.0000 
       1.5        100        3.5          3 19214.0000 19213.9936  0.0000 
 
       1.5         50          1          3 4625.25000 4625.26252  0.0000 
       1.5         50       3.25          3 4613.43750 4613.44079  0.0000 
       1.5         50        5.5          3 4632.00000 4632.00054  0.0000 
       1.5         50       7.75          3 4680.93750 4680.94176  0.0000 
       1.5         50         10          3 4760.25000 4760.26447  0.0000 
 
       1.5         50        3.5          2 4626.00000 4626.00197  0.0000 
       1.5         50        3.5      2.625 4617.56250 4617.56508  0.0000 
       1.5         50        3.5       3.25 4612.25000 4612.25261  0.0000 
       1.5         50        3.5      3.875 4610.06250 4610.06456  0.0000 
       1.5         50        3.5        4.5 4611.00000 4611.00092  0.0000 
 
The RMS error of the RS = 0.000246 
 
 Execution time: 
    0 hours, 0 minutes, 5 seconds 
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Limit state function: g=x1^3+x2^3-18  
 Random variables: X1~N(10,5), X2~N(9.9,5)
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18.5 Example 5 – Most probable point search using the adaptive response surface method (ASRM)   
 
This example illustrates a Most Probable Point (MPP) search on a nonlinear limit state using the simple 
cubic expression discussed in detail in Reference 1, Section 5.3 and depicted in Figure 18.5.1: 
 
               y = x13 + x23 – 18 
         

 
To run this problem, first use the File > Open… menu to select the Cubic.tre configuration file.  Then 
select Designs > MPP search  to display the MPP Search Manager dialog (see Fig. 15.1). Finally, click 
the Perform search button to commence the search.  Upon completion the solution vector is posted in the 
right-most column of the  Design variables table and an iteration summary is posted in the lower right 
corner. Note that the independent variables listed in this dialog are the same as those stated in the problem 
definition (x1 and x2) -- not the transformed standard normal space variables x1’ and x2’ discussed in the 
Theoretical Manual and in the plot above. After the solution is obtained, you may examine the search 
history by clicking the Show iteration history button which will display a tabular history of the search 
iterations: 
 

Figure 18.5.1 – Limit state 
function in standard normal 
variable space (x1’ and x2’). 

Iteration history: Saturday, March 01, 2008, 19:14 PM 
Problem: Cubic   Merit criterion (f):   Y =  X1^3 +   X2^3 - 18  
   N     x[1]     Lower[1]   Upper[1]     x[2]     Lower[2]   Upper[2]   
   0   5.000000  -3.500000  13.500000  -2.600000 -11.100000   5.900000    
   1   3.968080  -0.281920   8.218080   2.597267  -1.652733   6.847267      
   2   2.923463   0.798463   5.048463   2.549540   0.424540   4.674540    
   3   2.275700   1.213200   3.338200   2.156280   1.093780   3.218780    
   4   2.135917   1.604667   2.667167   2.049307   1.518057   2.580557    
   5   2.091327   1.825702   2.356952   2.069820   1.804195   2.335445    
   6   2.083467   1.817842   2.349092   2.077247   1.811622   2.342872    
   7   2.083467                         2.077247                       
 
   N Trust size   epsilon   f u-space   f x-space      g 
   0  1.000000   1.059744   1.8943491  62.0006680 127.731776 
   1  0.500000   0.209141   2.0406532  23.5581800  38.477313 
   2  0.250000   0.151559   2.1875101   3.8111386  20.832179 
   3  0.125000   0.035204   2.2224058   0.3507471   3.596301 
   4  0.062500   0.009816   2.2258376   0.0141572   0.336352 
   5  0.031250   0.002163   2.2259106   0.0072123   0.013247 
   6  0.031250   0.000000   2.2259106   0.0072123   0.006305 
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18.6  Example 6 -  Progressive failure analysis of a 4-component system.  
 
This example illustrates the use of the Progressive Failure Manager using the simple 4-component 
structural model previously illustrated in Figure 15.1.  Begin this example by selecting Progressive 
failure test.tre from the File > Open menu.  This will display the configuration shown in Figure 15.1.  
Now select Tools > Progressive failure analysis to display the Progressive Failure Manager (Fig. 
18.6.1).  
 
Initially, results table in the lower portion will be blank, but clicking the Execute button will populate it 
with the dominant failure sequences and corresponding failure probabilities.  In this example we are not 
actually performing a FEA of these structural elements because doing so requires a considerable amount 
of execution time and also requires a FEA code which is not included in the PRODAF installation. 
Instead, an emulator is used (included with the installation and listed in Appendix D) to calculate the 
failure probabilities given a failure sequence. 

Figure 18.6.1 – Progressive Failure Manager for example problem 6. 
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18.7 Example 7 – Probabilistic reliability of a 3-component rotor assembly 8 

 
In this example, a simple generic 3-component rotor assembly was designed and analyzed. The assembly 
consists of a shaft, a disk, and a set of 24 fan blades as depicted in the finite-element models shown in 
Figure 18.7.1. To retain simplicity yet still demonstrate the PRODAF design process, this example 
focuses on the structural portion of the total design process (i.e., the aerodynamic portion is assumed 
completed). Attaining a specified reliability for the entire assembly is the design objective and the stress-
strength failure mode is used to determine the failure risk of each component. These components are 
subjected to thermal, inertia and pressure loadings. The inertia load is from rotation of the assembly at an 
angular velocity of 1800 rpm. The temperature profile on the blade varies from 400 °F at the root to 700 
°F at the tip. The temperature of the rotor and the shaft is assumed to be constant at 600 °F. 

The shaft is 72 inches long, has a 3 inch diameter, and was modeled with 864 eight-node brick elements 
and 1225 nodes. Both ends of the shaft are held against translation and rotation in the transverse 
directions. One end is held against axial translation. Inertia forces are applied at the outer surface of the 
midpoint in the tangential direction on the main coordinate axes. 
 
The disk has a 12 inch outer diameter, 3 inch inner diameter, and is 2 inches thick uniformly. The disk 
model has 576 eight-node brick elements and 840 nodes. 
 
Each of the 24 fan blades has a tapered chord varying from 2.2 inches at the root to 2.9 inches at the tip. 
Their height linearly decreases from 2.9 inches at the leading edge to 2.2 inches at the trailing edge while 
the thickness varies from 0.170 inches at the root to 0.025 inches at the tip.  The blade model has 900 
four-node shell elements and 961 nodes. 
 
The basic material properties were the same for all 3 components; namely: 
 

Young’s 
modulus, psi 

Density,       
lb-sec2/in4 

Thermal 
expansion 
coefficient, 

in/in/°F 
29.246 x 106  74.790 x 10-5  6.8 x 10-6  

 
                     
8  This example requires ANSYS, NESTEM, and QRAS 1.7, none of which are provided in the PRODAF installation 

    Figure 18.7.1a – Rotor assembly structural model.            Figure 18.7.1b – Single fan blade FEM. 
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Uncertainties were assumed to be in the shaft rotation speed, the 3 basic material properties, and the 
strength as characterized by 9-terms in an equation that accounted for degradation due to temperature and 
number of load cycles. Hence there were a total of 12 random variables each of which was assigned a 
coefficient of variation of 0.01.  
 
The probabilistic FEM structural analysis code NESTEM uses lengthy text-based input files to set up 
calculations of the failure probability for each component.  The NESTEM output files were then harvested 
for these failure probability values.  Finally, the failure data were incorporated into database tables for the 
QRAS Interface code. Since there are 24 fan blades in this example, the NESTEM blade failure probability 
was multiplied by 24 to yield a 
failure probability for the entire 
set of blades. Finally, QRAS was 
invoked to determine the system 
level failure probability. The 
QRAS fault tree simulation 
consisted of 3 phases: Start, Run, 
and Stop with durations of 1000, 
49000, and 300 seconds, 
respectively. To retain simplicity, 
the failure rates for the Run and 
Stop phases were just assigned, 
while NESTEM provided the 
physics-based failure probabilities 
for the Start phase. Event 
sequence diagrams were defined 
for each component with a loss of 
mission defined if any component 
fails. The results are summarized 
in the table below and Figure 
18.7.2. 
    
 
     Rotor Assembly Failure 
Probabilities 

Component Mean failure 
probability 

Shaft 0.000000001 

Disk 0.035110000 

Single fan blade 0.001430358 

  

System Mean failure 
probability 

Assembly (shaft, disk, 
24 blades) 0.06818 

19.0  References 
 
 

            Figure 18.7.2 – CDF for the fan rotor assembly. 
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Figure A-1 – Probabilistic analyses recognize input uncertainties 
and yield more information but require more computational effort. 

20.0  Appendix A – Probabilistic Analysis Overview 
 

Simulation problems are traditionally treated deterministically; that is, it is assumed that all of the input 
information needed to perform a simulation can be represented by a set of single values (i.e., mean 
values). Hence, deterministic simulations lead to solutions with single values for the dependent variables. 
In reality, however, there is always some degree of uncertainty in the input data due to a whole spectrum 
of causes such as manufacturing geometry tolerances, non-uniform material properties, control system 
errors, environmental variances, and technology progress assumptions.  In many situations it would be 
more useful to perform probabilistic simulations that do account for such input uncertainties.  Such 
simulations yield probability curves instead of a single numerical answer and automatically provide 
valuable sensitivity information that identify the most important uncertainties.  This information can help 
guide future R&D efforts to achieve the most impact for the resources allotted, determine risks 
quantitatively, or be exploited in other ways. 

To illustrate these differences, consider the example in the upper box of Figure A-1 in which there are 3 
input variables (A ,B, and C) all with a single value and the result Y produced by the simulation is also a 
single value.  No input uncertainties are captured in this deterministic analysis.  

In the traditional probabilistic 
analysis, a statistical methodology 
known as Monte Carlo is used to 
calculate the effects of input variable 
uncertainties. Each input variable with 
uncertainty is represented by a 
probability density function (PDF) 
curve.  Such input variables are often 
called “random variables” to denote 
uncertainty. The statistical analysis 
uses this information together with a 
random number generator to select 
many sets of specific input values to 
pass on to the simulation code.  The 
totality of successive simulation 
results is used to produce a probability 
density function for the response 
variable (i.e., the dependent output 
variable) as illustrated in Figure A-1.  
This process also yields sensitivity 
data that identifies the random 
variables having the most influence on 
the response variable.  

Probabilistic analyses provide useful quantitative information that can be used by managers to make key 
decisions regarding future R&T investments.  They can also be used by designers to help design key 
components with specified failure risks.  
 
Although generally more powerful and useful than deterministic analyses, probabilistic analyses demand 
more information from the analyst to yield reasonable results. Frequently this means making common 
sense assumptions for information such as the PDF’s that is unknown. These assumptions are often based 
on the knowledge of experts and their collective experience.  
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Probabilistic analyses also require considerably longer execution times than deterministic analyses and 
this may be a significant deterrent especially for long running codes such as CFD and FEA simulations. 
The Monte Carlo simulation technique mentioned previously provides an asymptotically exact solution as 
the number of random sampling points approaches infinity. However, since it requires many simulation 
runs to generate a reasonably accurate answer, it is seldom used for complex, time-consuming 
simulations.  Instead, approximate solution methods are usually used that trade some accuracy to gain 
considerable computational speed.  One such method is called Fast Probability Integration (FPI).  It can 
yield quite acceptable accuracy with several orders of magnitude reduction in computational time 
compared to a Monte Carlo simulation.  An implementation of FPI was developed under NASA-
sponsorship (ref. 2) and was selected as the method of choice for conducting probabilistic analyses within 
PRODAF. 

A CDF curve often displayed instead of a PDF curve.  It is the integral of a PDF curve and reveals the 
probability of not exceeding specific response values along the x-axis. 
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21.0  Appendix B – Distribution Types 
 
Selecting an appropriate type of uncertainty distribution is not always obvious, especially for less 
experienced analysts.  Some general guidelines for selecting distribution types is offered here.  Additional 
information may be found in numerous text books (e.g., Ref. 5) as well as on several Internet sites. 
 
• Normal – A common symmetrical bell-shaped distribution. Often used to model various physical, 

mechanical, electrical, and chemical properties. For example, the tensile strength of a material, 
dimensions of fabricated parts, material hardness, wind velocity, and combustion chamber 
pressure. 

• Weibull - The Weibull distribution is frequently used in reliability and life data analyses to model 
failure times due to its versatility in shaping. For example, the life of antifriction bearings or other 
mechanical or electrical parts, corrosion life, wearout life. The Weibull distribution is a special 
case of the more general Extreme Value distribution (Type III). In PRODAF, the 2-parameter 
Weibull distribution is permitted. 

• Lognormal - The lognormal distribution is used extensively in reliability applications to model 
failure times due to its asymmetrical shape where occurrences are concentrated at the tail end of 
the range, and where differences in events are of a large order of magnitude. The lognormal and 
Weibull distributions are probably the most commonly used distributions in reliability 
applications.  

• Fréchet – The Fréchet distribution is a special case of the generalized extreme value distribution. 
The Fréchet distribution is not commonly used. However, it is important for modeling the 
statistical behavior of materials properties for a variety of engineering applications. For example, 
modeling interfacial damage in microelectronic packages and material properties of constituent 
particles in an aluminum alloy.  

• Uniform – By definition this distribution has a constant value over a specified interval (and zero 
elsewhere).  Sometimes useful in situations where nothing can be presumed about the distribution 
shape. 

• Beta – The shapes that this distribution can represent are quite variable – from near-Normal shapes 
to “bathtub shapes.” Hence, it can be used whenever a specific distribution shape is already 
known.  

• Modified Beta – This 3-parameter distribution is not well-known, but was developed specifically 
for conceptual design engineering applications wherein the analyst can only guess at a most likely 
value, a minimum value, a maximum value, and lacks any knowledge of the distribution shape. In 
such situations, engineers will find this distribution quite useful.  PRODAF transforms these 3 
parameters into an equivalent 4-parameter Beta distribution using an analogy with Normal 
distributions to determine the shape parameter (see Ref. 6 for details).       

• Extreme Value - Its importance arises from the fact that it is the limit distribution of the maxima 
of a sequence of independent and identically distributed random variables. Because of this, it is 
used as an approximation to model the maxima of long (finite) sequences of random variables. 
One  application of the Extreme Value disribution is modeling air pollution data. 

• Maximum Entropy - If nothing is known about a distribution except that it belongs to a certain 
class, then the maximum entropy distribution for that class is sometimes chosen, according to the 
principle of maximum entropy. The motivation is twofold: first, maximizing entropy, in a sense, 
means minimizing the amount of prior information built into the distribution; second, many 
physical systems tend to move towards maximal entropy configurations over time. Maximum 
Entropy modeling has been successfully applied to computer vision, spatial physics, natural 
language processing and many other fields. 
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• Curve fit – A user-defined polynomial distribution to fit unusual shapes. Not commonly used.   
• Truncated Normal – Same as Normal, but with upper and lower cutoffs of the tails. 
• Truncated Weibull – Same as Weibull, but with upper and lower cutoffs of the tails. 

 
 
Although any of these distribution types may be selected within the Uncertainty Definition dialog, users 
are cautioned that the FPI methodology requires that all distribution types must be internally transformed 
into standard normal distributions in order for FPI to generate CDF/PDF curves.  This mapping 
introduces some unavoidable errors that are generally not serious for typical engineering design 
applications, but more importantly, introduces some numerical instability into the calculations that 
sometimes results in noisy CDF/PDF curves.  If the magnitude of this difficulty is too large, FPI can even 
fail to converge to a solution. In such cases, users may retreat to adopting a “safe distribution” – namely, a 
Normal distribution that is very reliable. 
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22.0  Appendix C – PRODAF Main Menu Reference 
 
Four of the top-level items (File, Edit, View, and Help) in the main menu of PRODAF provide standard 
functionality of file manipulation, editing, and help. Two menu items invoke PRODAF-specific tools; 
namely the Tools and Designs selections (Fig. C1). 
 
 
 
 
 
 
 
 
 
 
 
 
 
Tools menu: 
• Atmosphere – Provides atmospheric properties as a function of altitude.9 
• Calculator – Simple numerical calculator. 
• Gas tables – Provides gas properties for several types of fluid flow problems (e.g., ideal channel 

flow, flow through normal or oblique shocks, isentropic turning flow).7 
• Database viewer – Invokes a dialog that displays the contents of binary or text databases.  
• Code database editor – Displays an editing dialog to modify/add/delete entries in a database that 

PRODAF uses to identify codes, their installation locations, and other properties.   
• Interface editor – A dialog to assist users setup a data transfer interface between a pair of codes.  
• QRAS Database Interface – Special interface to modify QRAS 1.7 binary database using 

probabilistic input from component-level reliability codes such as NESTEM and CALCE. 
• Data sampling – Displays a dialog that enables users to generate a set of random points for given 

a distribution type. Plots the random points on the PDF curve and creates an output dataset.. 
• Progressive failure analysis – Performs a branch and bound method to identify significant failure 

sequences for structures that experience multiple component-level failures before a total system-
level failure occurs.  

• Probabilistic Manager – This generic tool performs probabilistic analyses utilizing existing 
deterministic codes and a Fast Probability Integration code.    

 
Designs menu: 
• Define a new process – Erases the contents of the Design Process Manager window. 
• Single design point evaluation – Calculates the merit criterion for a single set of design variables. 
• Parametric analysis – Parametrically varies each design variable over a user-specified range and 

optionally creates a response surface model of the response function for a complete design process 
involving multiple codes. 

                     
9 This tool is not included in the PRODAF distribution.  It is a commercial product included (optionally) with the 
book entitled  “Aircraft Engine Design” (Ref. 6).  

Figure C1 – Primary PRODAF main menu options.  
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• Optimize design variables – Optimizes a set of design variables for a complete design process 
involving multiple codes. Optionally, utilizes a response surface model generated with an Optimal 
Symmetric Latin Hypercube. 

• MPP search – Locates the Most Probable Point (MPP) for probabilistic problems using an 
adaptive search procedure that represents the response function in a sequence of progressively 
smaller regions.  
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23.0  Appendix D – Example Progressive Failure Code (ConditionalFailProb)  
 

void main (int argc, char* argv[]) { 
  // Emulates a conditional failure FEA. 
  // j is the failure sequence 
  // j is determined via a single calling argument (e.g., argv[1]="3,1,2,4,") 
  // Returns the conditional failure probability of the system (Pf) 
  int j[] = {0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0}; // allow 20 components 
  double Pf = 0.; 
  char c; int i=0, k=1;  if (argc < 2) return; 
  while ((c=argv[1][i]) != NULL) { 
    if (c >='0' && c <='9') j[k] = 10*j[k]+c-'0'; 
    else k++; 
    i++; 
  } 
  if (j[1]==1 && j[2]==0 && j[3]==0 && j[4]==0) Pf = 0.106; 
  if (j[1]==2 && j[2]==0 && j[3]==0 && j[4]==0) Pf = 0.001; 
  if (j[1]==3 && j[2]==0 && j[3]==0 && j[4]==0) Pf = 0.08; 
  if (j[1]==4 && j[2]==0 && j[3]==0 && j[4]==0) Pf = 0.0001; 
  if (j[1]==1 && j[2]==2 && j[3]==0 && j[4]==0) Pf = 0.0014; 
  if (j[1]==1 && j[2]==3 && j[3]==0 && j[4]==0) Pf = 0.0095; 
  if (j[1]==1 && j[2]==4 && j[3]==0 && j[4]==0) Pf = 0.00005; 
  if (j[1]==3 && j[2]==2 && j[3]==0 && j[4]==0) Pf = 0.001; 
  if (j[1]==3 && j[2]==1 && j[3]==0 && j[4]==0) Pf = 0.016; 
  if (j[1]==3 && j[2]==4 && j[3]==0 && j[4]==0) Pf = 0.0005; 
  if (j[1]==1 && j[2]==3 && j[3]==2 && j[4]==0) Pf = 0.0028; 
  if (j[1]==1 && j[2]==3 && j[3]==4 && j[4]==0) Pf = 0.00006; 
  if (j[1]==3 && j[2]==1 && j[3]==2 && j[4]==0) Pf = 0.005; 
  if (j[1]==3 && j[2]==1 && j[3]==4 && j[4]==0) Pf = 0.00009; 
  if (j[1]==1 && j[2]==3 && j[3]==2 && j[4]==4) Pf = 0.0014; 
  if (j[1]==3 && j[2]==1 && j[3]==2 && j[4]==4) Pf = 0.0025; 
  if (j[1]==1 && j[2]==2 && j[3]==3 && j[4]==0) Pf = 0.0004; 
  if (j[1]==1 && j[2]==2 && j[3]==4 && j[4]==0) Pf = 0.0005; 
   
  FILE *file; file = fopen ("PfResult","w");  
  fprintf (file,"%f",Pf); 
  fclose (file); 
} 
 
  return; 
}  
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24.0  Appendix E – Example Interface code (NEPP_to_FLOPS) 
 
 

/* NEPP_to_FLOPS.cpp : Defines the entry point for the console application. 
 This interface modifies an NEPP output file to be a FLOPS engine deck input file. 
 The first 2 lines of a NEPP output file look like this: 
 
0.000       0.0   0.   88321.7       0.0   25247.3            26.75262  7678.643 
0.000       0.0   0.   88321.7       0.0   25247.3            26.75262  7678.643 
   
 The corresponding FLOPS input file must look like this: 
 
  MN       Alt   PC    Thrust       Ram      Fuel      TSFC       NOX    Exit A 
0.00       0.0  50.   88321.7       0.0   25247.3  0.285856  26.75262  7678.643 
0.00       0.0  50.   88321.7       0.0   25247.3  0.285856  26.75262  7678.643 
*/  

   
CWinApp theApp; 
 
using namespace std; 
 
int _tmain (int argc, TCHAR* argv[], TCHAR* envp[]) 
{ 
  int n1=0, n2=0; double TSFC; 
  CString sTSFC; 
 
 // initialize MFC or print error if fails 
 if (!AfxWinInit(::GetModuleHandle(NULL), NULL, ::GetCommandLine(), 0)) { 
  cerr << "Fatal Error: MFC initialization failed" << endl; 
  return 1; 
 } 
 else {  
    // proceed with the file conversion. If arguments are supplied, use them. 
    CString sNEPPoutput, sFLOPSinput, sLine, sInstallPath, sDBcodePath,      
             sPaths; 
     
    if (__argc > 2) {  
      sNEPPoutput = __argv[1]; 
      sFLOPSinput = __argv[2]; 
    } 
    else {  
      AfxMessageBox ("Wrong number of arguments calling NEPP_to_FLOPS        
                        interface. Should be 2."); 
      return 1; 
    } 
    TRACE2 ("sNEPPoutput=%s  sFLOPSinput=%s",sNEPPoutput,sFLOPSinput); 
     
    // convert the NEPP output file into a FLOPS input file 
    CStdioFile sFile, dFile; // source file, destination file 
retry1: 
    n1++; 
    if (!sFile.Open (sNEPPoutput, CFile::modeRead | CFile::typeText)) { 
      if (n1<100000) goto retry1; 
      else AfxMessageBox ("Failed to open NEPP output file: " + sNEPPoutput, 
                             MB_ICONSTOP);  
      return 2; 
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    } 
retry2: 
    n2++; 
    if (!dFile.Open (sFLOPSinput, CFile::modeWrite | CFile::modeCreate |     
          CFile::typeText)) {  
      if (n2<100000) goto retry2; 
      else AfxMessageBox ("Failed to open FLOPS input file: " + sFLOPSinput); 
      return 3; 
    } 
 
    // Alert user to multiple open file attempts 
    CString sn1, sn2; sn1.Format("%d",n1); sn2.Format("%d",n2); 
    if (n1>1) AfxMessageBox ("Trys to open NEPP output file: " + sn1);  
    if (n2>1) AfxMessageBox ("Trys to open FLOPS input file: " + sn2); 
     
    // All is well, so write the input file for FLOPS 
    dFile.WriteString ("  MN       Alt   PC    Thrust       Ram      Fuel    
                         TSFC       NOX    Exit A\n"); 
    while (sFile.ReadString(sLine)) { 
      sLine = sLine.Left(4) + " " + sLine.Mid(6); // remove last 0 from Mach 
               number field 
      TSFC = atof(sLine.Mid(40,10))/atof(sLine.Mid(20,10)); 
      sTSFC.Format ("%10.6f",TSFC); 
      sLine = sLine.Left(16) +"50." + sLine.Mid(19,30) + sTSFC +             
               sLine.Mid(59); 
      dFile.WriteString(sLine +"\n");  
    } 
    sFile.Close(); dFile.Close(); 
   return 0; 
  } 
} 


